php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76079 Attaching PRs to bug issues broken
Submitted: 2018-03-10 16:33 UTC Modified: 2018-10-23 02:46 UTC
Votes:7
Avg. Score:4.3 ± 0.9
Reproduced:7 of 7 (100.0%)
Same Version:6 (85.7%)
Same OS:6 (85.7%)
From: cmb@php.net Assigned: petk (profile)
Status: Closed Package: Systems problem
PHP Version: Irrelevant OS: n/a
Private report: No CVE-ID: None
 [2018-03-10 16:33 UTC] cmb@php.net
Description:
------------
Since several days trying to attach Github pull requests to bug
tracker tickets does not work anymore.  After selecting the repo
and the PR and saving, the system reports:

| Failed to retrieve pull request from GitHub
| Could not attach pull request to Bug #12345



Patches

require_pear.diff (last revision 2018-09-17 04:11 UTC by zrhoffman at ku dot edu)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-03-31 05:02 UTC] carusogabriel34 at gmail dot com
Is something related to the GitHub API url: https://3v4l.org/aEn0c
 [2018-04-09 15:09 UTC] levim@php.net
Someone suggested to me that this might be the issue:

https://githubengineering.com/crypto-deprecation-notice/
 [2018-06-02 21:36 UTC] labs at strongholdmedia dot eu
Guess there is no public repository to check this issue, so it must be found by the internal council.
(It would possibly be hard to test it anyway.)
 [2018-08-08 15:20 UTC] bugs dot php dot net at majkl578 dot cz
Still doesn't work, getting HTTP/1.0 500 Internal Server Error and blank page now.
 [2018-08-09 11:48 UTC] cmb@php.net
I guess Bug_Pulltracker::getDataFromGithub()[1] is failing.

[1] <https://github.com/php/web-bugs/blob/8fde831/include/classes/bug_ghpulltracker.php#L14-L27>
 [2018-09-17 04:15 UTC] zrhoffman at ku dot edu
I am probably missing something, but it started working for me locally once I required PEAR.php.
 [2018-10-23 02:46 UTC] petk@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: petk
 [2018-10-23 02:46 UTC] petk@php.net
Attaching GitHub pull requests has been fixed via http://git.php.net/?p=web/bugs.git;a=commit;h=8fe6914127b3b3da776a67c25db29ae8e0a5b16c

thanks to @zrhoffman

This will also need to be resolved using a different consuming of the GitHub API in the near future due to possible rate limits and other limitations. Additionally, would be good to get the PEAR dependency refactored for handling the errors to not depend on outdated PEAR.

Thank you @zrhoffman

I'm closing this issue for now and will recheck options to improve this further more. Using GitHub is very practical and essential to track progress of the bugs here, I believe.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Sep 23 18:01:26 2019 UTC