php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76052 libsodium seems not active in PHP 7.2.3
Submitted: 2018-03-05 14:27 UTC Modified: 2018-03-05 14:53 UTC
From: it-solutions at schultz dot ch Assigned:
Status: Not a bug Package: *Encryption and hash functions
PHP Version: 7.2.3 OS: Windows Srv 2012
Private report: No CVE-ID: None
 [2018-03-05 14:27 UTC] it-solutions at schultz dot ch
Description:
------------
WINDOWS / APACHE 2.4 / PHP 7.2.3

After updating to PHP 7.2.3 (from 7.2.1) I receive the following error, when trying to use a lib-sodium function:

mod_fcgid: stderr: PHP Fatal error:  Uncaught Error: Call to undefined function Sodium\\crypto_secretbox_open() in ...

When using PHP 7.1.15 (with manually activated LIB-SODIUM) the program works without errors.

As far as I know, libsodium should be available as core-extension in PHP 7.2 (and I think this worked in PHP 7.2.0)

Am I missing something here?
Kind regards
Ruediger Schultz
Schultz IT Solutions


Note:
https://bugs.php.net/bug.php?id=74826 refers to PHP 7.2.0-alpha and was fixed.
Maybe the underlying cause "reappeared" in PHP 7.2.1 or later...



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-03-05 14:53 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2018-03-05 14:53 UTC] requinix@php.net
What you're missing was mentioned in my first comment to that bug report:

> Note that it will use global functions and constants, not a namespace.

http://php.net/manual/en/book.sodium.php
http://php.net/manual/en/function.sodium-crypto-secretbox-open.php
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Jul 21 12:01:26 2019 UTC