php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #75866 PDO bug
Submitted: 2018-01-24 02:40 UTC Modified: 2018-01-24 08:33 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: berkaykarats at icloud dot com Assigned:
Status: Not a bug Package: PDO related
PHP Version: 7.0.27 OS: KDE neon
Private report: No CVE-ID: None
 [2018-01-24 02:40 UTC] berkaykarats at icloud dot com
Description:
------------
$data = $db->query("SELECT COUNT(id) FROM users");
print_r($data) outputs -> [COUNT(id)] => 3 
but i cant access COUNT(id) because parenthesis are malfunction of function.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-01-24 08:33 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2018-01-24 08:33 UTC] requinix@php.net
Fetch as an array and use $var["COUNT(id)"]. Or use an alias.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Jul 24 08:01:31 2024 UTC