php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #75822 PHP failed to build
Submitted: 2018-01-16 06:49 UTC Modified: 2018-01-16 11:10 UTC
From: 1518134125 at qq dot com Assigned: derick (profile)
Status: Closed Package: *General Issues
PHP Version: master-Git-2018-01-16 (Git) OS: Windows Server 2016
Private report: No CVE-ID: None
 [2018-01-16 06:49 UTC] 1518134125 at qq dot com
Description:
------------
Environment: Windiows Server 2016 + VS2015 update3

I tried to build PHP with master branch latest revision on Windows.It failed to build due to the error C2059,C2061,C2065,C2109. This issue can be reproduced from master revision 022e029(https://github.com/php/php-src/commit/022e029984b431c014545630d4dfac811607754b). Could you please help take a look at this? Thanks in advance!

Expected result:
----------------
Build successfully.

Actual result:
--------------
Zend\zend_variables.c(47): error C2059: syntax error: '('
Zend\zend_variables.c(49): error C2061: syntax error: identifier 'zend_zval_dtor_func'
Zend\zend_variables.c(49): error C2059: syntax error: ';'
Zend\zend_variables.c(49): error C2059: syntax error: '['
Zend\zend_variables.c(67): error C2065: 'zend_zval_dtor_func': undeclared identifier
Zend\zend_variables.c(67): error C2109: subscript requires array or pointer type
Zend\zend_virtual_cwd.c(655): warning C4267: '=': conversion from 'size_t' to 'uint16_t', possible loss of data
Zend\zend_virtual_cwd.c(662): warning C4267: '=': conversion from 'size_t' to 'uint16_t', possible loss of data
NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\VC\Tools\MSVC\14.10.25017\bin\HostX86\x86\cl.exe"' : return code '0x2'
Stop.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-01-16 11:10 UTC] derick@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: derick
 [2018-01-16 11:10 UTC] derick@php.net
The fix for this bug has been committed.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.

 For Windows:

http://windows.php.net/snapshots/
 
Thank you for the report, and for helping us make PHP better.

Looks like this is fixed already:

https://github.com/php/php-src/commit/022e029984b431c014545630d4dfac811607754b#diff-91d8f402f8b164f410cb808dc178f9faR47
 [2018-01-18 08:02 UTC] 1518134125 at qq dot com
Thank you so much for fixing this issue. I've verified your fix works well.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Tue Dec 18 20:01:26 2018 UTC