php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #75808 php-cgi.exe - Entry Point Not Found
Submitted: 2018-01-12 03:48 UTC Modified: 2018-01-12 16:57 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: dwi at gemanusa dot com Assigned:
Status: Not a bug Package: Systems problem
PHP Version: 7.2.1 OS: windows Server 2008 Standard (6.
Private report: No CVE-ID: None
 [2018-01-12 03:48 UTC] dwi at gemanusa dot com
Description:
------------
When run the php-cgi.exe error occurred like :

php-cgi.exe - Entry Point Not Found
-----------------------------------
The procedure entry point K32GetProcessMemoryInfo could not be located in the dynamic link library KERNERL32.dll.




Test script:
---------------
php-cgi.exe - Entry Point Not Found
-----------------------------------
The procedure entry point K32GetProcessMemoryInfo could not be located in the dynamic link library KERNERL32.dll.

Expected result:
----------------
I have search for implement it from microsoft : https://msdn.microsoft.com/en-us/library/windows/desktop/ms683219(v=vs.85).aspx


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-01-12 16:57 UTC] ab@php.net
-Status: Open +Status: Not a bug
 [2018-01-12 16:57 UTC] ab@php.net
Thanks for the report. PHP 7.2 doesn't support systems below Windows 7/Server 2008 R2. Please see UPGRADING.

Thanks.
 [2019-02-12 13:54 UTC] starvin9 at gmail dot com
Is Php 7.2 has OS restriction in the linux as similar to the Windows ?
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Jul 20 07:01:25 2019 UTC