php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #75766 Three Timezone is missing in PHP 5.6.32 resulted serious issues in the platform
Submitted: 2018-01-05 14:06 UTC Modified: 2018-01-06 13:16 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: axsinha at cambridge dot org Assigned: cmb (profile)
Status: Not a bug Package: timezonedb (PECL)
PHP Version: 5.6.33 OS: CentOS
Private report: No CVE-ID: None
 [2018-01-05 14:06 UTC] axsinha at cambridge dot org
Description:
------------
Hi Team,

We have recently updated the PHP version in our platform to PHP 5.6.32. Below are the three timezone which are missing in the version - 

1. Asia/Istanbul
2. Chile/Continental
3. Australia/Queensland

We have lot of users from these regions specially Turkey and all of these users are affected because of this. We have some functionalities which are dependent on the user's timezone and as these time zones are not available anymore, the functionalities are not working as expected. Also users from these regions are not able to see their timezone from the user profile page because of the missing values in the mentioned PHP version. Could you please provide us a patch to add these time zones back to the latest version?

Thanks & Regards,
Anup Sinha


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-01-06 13:16 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2018-01-06 13:16 UTC] cmb@php.net
Active support for PHP 5.6 has ended eleven months ago[1], so
there will be no more updates to the bundled timezonedb.  You
would have to update to a newer timezonedb, which is availe via
PECL[2].

[1] <http://www.php.net/supported-versions.php>
[2] <http://pecl.php.net/package/timezonedb>
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Aug 24 20:01:26 2019 UTC