php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #75726 ./configure: detecting openssl
Submitted: 2017-12-23 13:28 UTC Modified: -
Votes:3
Avg. Score:5.0 ± 0.0
Reproduced:3 of 3 (100.0%)
Same Version:0 (0.0%)
Same OS:2 (66.7%)
From: dpa-bugs at aegee dot org Assigned:
Status: Open Package: *Compile Issues
PHP Version: 7.1.12 OS:
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2017-12-23 13:28 UTC] dpa-bugs at aegee dot org
Description:
------------
openssl/Configure --prefix=/usr/local installs the .h files in /usr/local/include/openssl/ and on 64bit systems the libraries in /usr/local/lib64 .  Most other packackages put their libraries in /usr/local/lib, so PHP_LIBDIR is /usr/local/lib .

./configure --with-openssl=/usr/local does:

if test "$PHP_OPENSSL_DIR" = "yes"; then
  PHP_OPENSSL_DIR="/usr/local/ssl /usr/local /usr /usr/local/openssl"
fi

for i in $PHP_OPENSSL_DIR; do
  if test -r $i/include/openssl/evp.h; then
    OPENSSL_INCDIR=$i/include
  fi
  if test -r $i/$PHP_LIBDIR/libssl.a -o -r $i/$PHP_LIBDIR/libssl.$SHLIB_SUFFIX_NAME; then
    OPENSSL_LIBDIR=$i/$PHP_LIBDIR
  fi
  test -n "$OPENSSL_INCDIR" && test -n "$OPENSSL_LIBDIR" && break
done

meaning that is does not check for /usr/local/lib64/libssl.(a,so) and the detection for openssl always fails, if the paths are considers whenre openssl installs itself by default.

This happens in configure four times (on lines 18413, 31988 and 42880 and 94001).


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-01-11 23:02 UTC] levideinterstellaire at gmail dot com
Faced on RH 6.8 with openssl 1.0.2 or 1.1
PHP version 7.2.1 (latest as of date of post)

thks
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue May 21 01:01:27 2019 UTC