php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #75724 Annotate function removal Mcrypt functions
Submitted: 2017-12-23 11:22 UTC Modified: 2018-01-25 20:27 UTC
From: bugs dot php dot net_nospam at adviesenzo dot nl Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: 7.2.0 OS:
Private report: No CVE-ID: None
 [2017-12-23 11:22 UTC] bugs dot php dot net_nospam at adviesenzo dot nl
Description:
------------
---
From manual page: http://www.php.net/function.mcrypt-encrypt
---

A lot of the (most) Mcrypt functions do have the notice saying that they are deprecated as of PHP 7.1.0, but are missing the `and REMOVED as of PHP 7.2.0`


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-01-25 20:27 UTC] vrana@php.net
-Status: Open +Status: Not a bug
 [2018-01-25 20:27 UTC] vrana@php.net
It's still available in PECL. The version information is correct in the header:

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Aug 09 18:34:40 2020 UTC