php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #75706 Incompatible with PHP 7.1
Submitted: 2017-12-19 15:17 UTC Modified: 2017-12-19 16:07 UTC
Votes:3
Avg. Score:3.0 ± 1.6
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (50.0%)
From: jame2 at ceh dot ac dot uk Assigned: cmb (profile)
Status: Assigned Package: dbase (PECL)
PHP Version: 7.1.12 OS: Windows 10
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2017-12-19 15:17 UTC] jame2 at ceh dot ac dot uk
Description:
------------
The most recent available version of php_dbase.dll does not play with PHP 7.1. On starting the web server, the following is logged.

PHP Warning:  PHP Startup: dbase: Unable to initialize module
Module compiled with module API=20151012
PHP    compiled with module API=20160303
These options need to match

Using php_dbase-7.0.0beta1-7.0-ts-vc14-x86 with php-7.1.12-Win32-VC14-x86 on XAMPP.

I guess this is unsurprising but an update would be very welcome.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-12-19 16:07 UTC] cmb@php.net
-Assigned To: +Assigned To: cmb
 [2018-01-02 14:59 UTC] jiri at hrazdil dot info
php_dbase.dll compatible with PHP 7.1/VC14 and PHP 7.2/VC15 is available at https://github.com/nufue/pecl-dbase-windows
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC