php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #75603 Error during installation PDO_OCI-1.0
Submitted: 2017-11-30 16:06 UTC Modified: 2017-12-14 20:43 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: spereuda at gmail dot com Assigned:
Status: Not a bug Package: PDO OCI
PHP Version: 7.0.26 OS: Oracle Linux 6.8, x86_64
Private report: No CVE-ID: None
 [2017-11-30 16:06 UTC] spereuda at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/ref.pdo-oci
---

# make
/bin/sh /opt/PDO_OCI-1.0/libtool --mode=compile cc -I -I. -I/opt/PDO_OCI-1.0 -DPHP_ATOM_INC -I/opt/PDO_OCI-1.0/include -I/opt/PDO_OCI-1.0/main -I/opt/PDO_OCI-1.0 -I/var/local/php/php-7.1.2/include/php -I/var/local/php/php-7.1.2/include/php/main -I/var/local/php/php-7.1.2/include/php/TSRM -I/var/local/php/php-7.1.2/include/php/Zend -I/var/local/php/php-7.1.2/include/php/ext -I/var/local/php/php-7.1.2/include/php/ext/date/lib -I/usr/include/oracle/12.2/client  -DHAVE_CONFIG_H  -g -O2   -c /opt/PDO_OCI-1.0/oci_driver.c -o oci_driver.lo
libtool: compile:  cc -I -I. -I/opt/PDO_OCI-1.0 -DPHP_ATOM_INC -I/opt/PDO_OCI-1.0/include -I/opt/PDO_OCI-1.0/main -I/opt/PDO_OCI-1.0 -I/var/local/php/php-7.1.2/include/php -I/var/local/php/php-7.1.2/include/php/main -I/var/local/php/php-7.1.2/include/php/TSRM -I/var/local/php/php-7.1.2/include/php/Zend -I/var/local/php/php-7.1.2/include/php/ext -I/var/local/php/php-7.1.2/include/php/ext/date/lib -I/usr/include/oracle/12.2/client -DHAVE_CONFIG_H -g -O2 -c /opt/PDO_OCI-1.0/oci_driver.c  -fPIC -DPIC -o .libs/oci_driver.o
/opt/PDO_OCI-1.0/oci_driver.c: In function ‘pdo_oci_fetch_error_func’:
/opt/PDO_OCI-1.0/oci_driver.c:51: error: too many arguments to function ‘add_next_index_string’
/opt/PDO_OCI-1.0/oci_driver.c: In function ‘oci_handle_preparer’:
/opt/PDO_OCI-1.0/oci_driver.c:238: warning: passing argument 5 of ‘pdo_parse_params’ from incompatible pointer type
/var/local/php/php-7.1.2/include/php/ext/pdo/php_pdo_driver.h:678: note: expected ‘size_t *’ but argument is of type ‘int *’
/opt/PDO_OCI-1.0/oci_driver.c: At top level:
/opt/PDO_OCI-1.0/oci_driver.c:411: warning: initialization from incompatible pointer type
/opt/PDO_OCI-1.0/oci_driver.c:412: warning: initialization from incompatible pointer type
/opt/PDO_OCI-1.0/oci_driver.c:413: warning: initialization from incompatible pointer type
make: *** [oci_driver.lo] Error 1



Test script:
---------------
# make
/bin/sh /opt/PDO_OCI-1.0/libtool --mode=compile cc -I -I. -I/opt/PDO_OCI-1.0 -DPHP_ATOM_INC -I/opt/PDO_OCI-1.0/include -I/opt/PDO_OCI-1.0/main -I/opt/PDO_OCI-1.0 -I/var/local/php/php-7.1.2/include/php -I/var/local/php/php-7.1.2/include/php/main -I/var/local/php/php-7.1.2/include/php/TSRM -I/var/local/php/php-7.1.2/include/php/Zend -I/var/local/php/php-7.1.2/include/php/ext -I/var/local/php/php-7.1.2/include/php/ext/date/lib -I/usr/include/oracle/12.2/client  -DHAVE_CONFIG_H  -g -O2   -c /opt/PDO_OCI-1.0/oci_driver.c -o oci_driver.lo
libtool: compile:  cc -I -I. -I/opt/PDO_OCI-1.0 -DPHP_ATOM_INC -I/opt/PDO_OCI-1.0/include -I/opt/PDO_OCI-1.0/main -I/opt/PDO_OCI-1.0 -I/var/local/php/php-7.1.2/include/php -I/var/local/php/php-7.1.2/include/php/main -I/var/local/php/php-7.1.2/include/php/TSRM -I/var/local/php/php-7.1.2/include/php/Zend -I/var/local/php/php-7.1.2/include/php/ext -I/var/local/php/php-7.1.2/include/php/ext/date/lib -I/usr/include/oracle/12.2/client -DHAVE_CONFIG_H -g -O2 -c /opt/PDO_OCI-1.0/oci_driver.c  -fPIC -DPIC -o .libs/oci_driver.o
/opt/PDO_OCI-1.0/oci_driver.c: In function ‘pdo_oci_fetch_error_func’:
/opt/PDO_OCI-1.0/oci_driver.c:51: error: too many arguments to function ‘add_next_index_string’
/opt/PDO_OCI-1.0/oci_driver.c: In function ‘oci_handle_preparer’:
/opt/PDO_OCI-1.0/oci_driver.c:238: warning: passing argument 5 of ‘pdo_parse_params’ from incompatible pointer type
/var/local/php/php-7.1.2/include/php/ext/pdo/php_pdo_driver.h:678: note: expected ‘size_t *’ but argument is of type ‘int *’
/opt/PDO_OCI-1.0/oci_driver.c: At top level:
/opt/PDO_OCI-1.0/oci_driver.c:411: warning: initialization from incompatible pointer type
/opt/PDO_OCI-1.0/oci_driver.c:412: warning: initialization from incompatible pointer type
/opt/PDO_OCI-1.0/oci_driver.c:413: warning: initialization from incompatible pointer type
make: *** [oci_driver.lo] Error 1


Expected result:
----------------
Hello!
I'm trying to install PDO_OCI-1.0(you can find in atach PDO_OCI-1.0.tgz), but when I run the make command, I get the following error:

# make
/bin/sh /opt/PDO_OCI-1.0/libtool --mode=compile cc -I -I. -I/opt/PDO_OCI-1.0 -DPHP_ATOM_INC -I/opt/PDO_OCI-1.0/include -I/opt/PDO_OCI-1.0/main -I/opt/PDO_OCI-1.0 -I/var/local/php/php-7.1.2/include/php -I/var/local/php/php-7.1.2/include/php/main -I/var/local/php/php-7.1.2/include/php/TSRM -I/var/local/php/php-7.1.2/include/php/Zend -I/var/local/php/php-7.1.2/include/php/ext -I/var/local/php/php-7.1.2/include/php/ext/date/lib -I/usr/include/oracle/12.2/client  -DHAVE_CONFIG_H  -g -O2   -c /opt/PDO_OCI-1.0/oci_driver.c -o oci_driver.lo
libtool: compile:  cc -I -I. -I/opt/PDO_OCI-1.0 -DPHP_ATOM_INC -I/opt/PDO_OCI-1.0/include -I/opt/PDO_OCI-1.0/main -I/opt/PDO_OCI-1.0 -I/var/local/php/php-7.1.2/include/php -I/var/local/php/php-7.1.2/include/php/main -I/var/local/php/php-7.1.2/include/php/TSRM -I/var/local/php/php-7.1.2/include/php/Zend -I/var/local/php/php-7.1.2/include/php/ext -I/var/local/php/php-7.1.2/include/php/ext/date/lib -

Please help me to resolve this bug. Thank you.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-12-14 20:43 UTC] sixd@php.net
-Status: Open +Status: Not a bug
 [2017-12-14 20:43 UTC] sixd@php.net
It looks like you used the unmaintained PECL version.  The top of the PECL page mentions this is obsolete.

Use the PDO_OCI bundled with your version of PHP.  Run phpize etc as normal to add it.
 [2017-12-15 16:19 UTC] spereuda at gmail dot com
Good evening. Also, I have problem with installing the OCI8 extension:

#./configure --with-php-config=/var/local/php/php-7.1.2/bin/php-config --with-oci8=shared,instantclient,/usr/lib/oracle/12.2/client64/lib

#make
#make install

To enable the extension, I add a file named oci8.ini in /etc/php.d with this content:

extension=oci8.so

And now, when I run the php -v I get the follow warning:

PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/oci8.so' - /usr/lib64/php/modules/oci8.so: undefined symbol: _call_user_function_ex in Unknown on line 0

Warning: PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/oci8.so' - /usr/lib64/php/modules/oci8.so: undefined symbol: _call_user_function_ex in Unknown on line 0

The phpinfo.php script does not produce an "oci8" section saying "OCI8 Support enabled".

Please, help me install the oci8 extension.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Nov 12 07:01:37 2019 UTC