php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #75592 PdoAdapter->nextId('phpbt_comment')\n#2
Submitted: 2017-11-29 22:05 UTC Modified: 2017-11-30 08:07 UTC
From: kucherdominikus at yahoo dot de Assigned:
Status: Not a bug Package: PDO MySQL
PHP Version: 7.1.12 OS: Fedora 26
Private report: No CVE-ID: None
 [2017-11-29 22:05 UTC] kucherdominikus at yahoo dot de
Description:
------------
PHP Fatal error:  Uncaught PDOException: SQLSTATE[HY000]: General error: 126 Index for table './phpbugtracker/phpbt_comment_seq.MYI' is corrupt; try to repair it in /usr/share/phpbugtracker/inc/pdo_adapter.php:114\nStack trace:\n#0 /usr/share/phpbugtracker/inc/pdo_adapter.php(114): PDO->exec('insert into php...')\n#1 /usr/share/phpbugtracker/bug.php(694): PdoAdapter->nextId('phpbt_comment')\n#2 /usr/share/phpbugtracker/bug.php(1121): update_bug('6')\n#3 {main}\n  thrown in /usr/share/phpbugtracker/inc/pdo_adapter.php on line 114, referer: http://localhost/bugtracker/bug.php?op=show&bugid=6

Test script:
---------------
https://github.com/a-v-k/phpBugTracker


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-11-29 22:10 UTC] adambaratz@php.net
-Status: Open +Status: Feedback -Package: PDO Core +Package: PDO MySQL
 [2017-11-29 22:10 UTC] adambaratz@php.net
Based on the error, I'm guessing this is an issue with your MySQL setup rather than PDO. Could you take a look at the error on the top of the stack?
 [2017-11-29 22:15 UTC] kucherdominikus at yahoo dot de
-Status: Feedback +Status: Closed
 [2017-11-29 22:15 UTC] kucherdominikus at yahoo dot de
after i upgrade mariadb to 10.2.11 it works
 [2017-11-30 08:07 UTC] requinix@php.net
-Status: Closed +Status: Not a bug
 [2017-11-30 08:44 UTC] spam2 at rhsoft dot net
> after i upgrade mariadb to 10.2.11 it works

no, after something did implicit "repair table <tablename>"

the message "General error: 126 Index for table './phpbugtracker/phpbt_comment_seq.MYI' is corrupt; try to repair it" is pretty clear, the table "phpbt_comment_seq" is not clean, likely dirty shutdown or crash of the machine 

Dominik: please don't flood this php upstream bugtracker which has *nothing* to do with "phpbugtracker" on your machine with unrelated things
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Tue Nov 13 16:01:26 2018 UTC