php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #75587 Phar compilation fails
Submitted: 2017-11-29 05:43 UTC Modified: 2018-01-08 07:59 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: chingis at wodby dot com Assigned: bishop (profile)
Status: Closed Package: PHAR related
PHP Version: 7.1.12 OS: Alpine Linux 3.6
Private report: No CVE-ID: None
 [2017-11-29 05:43 UTC] chingis at wodby dot com
Description:
------------
Starting to happen after upgrade to 7.1.12:

re2c: error: cannot open source file: ext/phar/phar_path_check.re
make: *** [Makefile:193: /usr/src/php/ext/phar/phar_path_check.c] Error 1

---------------

The full log available in travis ci (docker image build), raw job output: https://s3.amazonaws.com/archive.travis-ci.org/jobs/308324276/log.txt?X-Amz-Expires=30&X-Amz-Date=20171129T053944Z&X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAJRYRXRSVGNKPKO5A/20171129/us-east-1/s3/aws4_request&X-Amz-SignedHeaders=host&X-Amz-Signature=a76605e0276ccb92b74a63b134985d027dabea72c5348fe86c62fc26c81100d4


Patches

Add a Patch

Pull Requests

Pull requests:

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-01-08 02:03 UTC] bishop@php.net
-Status: Open +Status: Feedback
 [2018-01-08 02:03 UTC] bishop@php.net
From my read of the attached PR, this does not appear to be a problem unique to phar, but rather an issue with how core extensions are built generally. Is that a proper characterization?
 [2018-01-08 02:03 UTC] bishop@php.net
-Assigned To: +Assigned To: bishop
 [2018-01-08 07:58 UTC] chingis at wodby dot com
Yes, it seems to be so. I guess we can close it.
 [2018-01-08 07:59 UTC] chingis at wodby dot com
-Status: Feedback +Status: Closed
 [2018-01-08 07:59 UTC] chingis at wodby dot com
Turned out to be the issue of how extensions installed in _/php docker images https://github.com/php/php-src/pull/2955
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat May 30 00:01:25 2020 UTC