php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7551 Can't start apache with libphp4.so
Submitted: 2000-10-31 12:18 UTC Modified: 2001-12-19 02:25 UTC
From: fr-delaby at chru-lille dot fr Assigned:
Status: Closed Package: Apache related
PHP Version: 4.0.3pl1 OS: DEC OSF1 v4.0 (alpha)
Private report: No CVE-ID: None
 [2000-10-31 12:18 UTC] fr-delaby at chru-lille dot fr
Here is the return message
> bin/apachectl start
Syntax error on line 225 of /usr/opt/apache/conf/httpd.conf:
Cannot load /usr/opt/apache/libexec/libphp4.so into server: dlopen: cannot load /usr/opt/apache/libexec/libphp4.so
bin/apachectl start: httpd could not be started
>

I saw no problems during compilation of php (only warnings).
Apache ran well with php3.0.15

I compiled all with cc.
I use dynamic library, apache 1.3.12, perl 5.6.0, oracle 8.0.5.1.
My configure options was 
./configure --with-apxs=/usr/opt/apache/bin/apxs \
            --with-xml \
            --with-oracle=/usr/opt/oracle/product/8.0.5.
For Apache, I used
./configure --prefix=/usr/opt/apache \
            --enable-shared=max \
            --with-perl=/usr/bin/perl

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-11-03 03:30 UTC] fr-delaby at chru-lille dot fr
I tried with --oci8 instead of  --oracle, but the result is the same.
I had --enable-versioning too (I use php3)... 
 [2000-12-04 09:24 UTC] sniper@php.net
Could you please check if this happens with PHP 4.0.4RC3:

http://www.php.net/distributions/php-4.0.4RC3.tar.gz

--Jani
 [2001-01-30 04:07 UTC] sniper@php.net
No feedback.

If propblem persist even when you have the required
(Oracle related) environment vars set, have configured/
compiled PHP 3 also with --enable-versioning and when
using the latest CVS snapshot, reopen this bug report.

--Jani

http://www.php.net/oci8

 [2001-12-18 14:44 UTC] derick@php.net
Duplicate of 14587
 [2001-12-19 02:25 UTC] fr-delaby at chru-lille dot fr
I go round the problem.
Now, I use static library with PHP 4.0.6.
May be I will try later with dynamic library...
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Jan 23 14:01:23 2021 UTC