php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #75503 ./configure: line 2550: syntax error near unexpected token `config.nice'
Submitted: 2017-11-08 18:33 UTC Modified: 2017-11-13 12:35 UTC
From: spam2 at rhsoft dot net Assigned:
Status: Not a bug Package: Compile Failure
PHP Version: 7.2Git-2017-11-08 (Git) OS:
Private report: No CVE-ID: None
 [2017-11-08 18:33 UTC] spam2 at rhsoft dot net
Description:
------------
7.2.0RC6 as well as current master:

+ ./configure --quiet --host=x86_64-redhat-linux --build=x86_64-redhat-linux --target=x86_64-redhat-linux --prefix=/usr --program-prefix= --libdir=/usr/lib64/php --disable-all --enable-bcmath=shared --enable-calendar=shared --enable-cli --enable-ctype=shared --enable-dom=shared --enable-exif=shared --enable-fileinfo=shared --enable-filter --enable-hash=shared --enable-huge-code-pages --enable-inline-optimization --enable-intl=shared --enable-json=shared --enable-libxml --enable-mbregex --enable-mbstring=shared --enable-mysqlnd=shared --enable-opcache=shared --enable-pcntl=shared --enable-pdo=shared --enable-phar=shared --enable-posix=shared --enable-re2c-cgoto --enable-session=shared --enable-shared --enable-simplexml=shared --enable-soap=shared --enable-sockets=shared --enable-tokenizer=shared --enable-xml=shared --enable-xmlreader=shared --enable-xmlwriter=shared --enable-zip=shared --with-apxs2=/usr/bin/apxs --with-bz2=shared,/usr --with-config-file-path=/etc --with-config-file-scan-dir=/etc/php.lounge.d --with-curl=shared,/usr --with-freetype-dir=/usr --with-gd=shared,/usr --with-gettext=shared,/usr --with-iconv=shared --with-imap-ssl=/usr --with-imap=shared,/usr --with-kerberos=/usr --with-layout=GNU --with-libdir=lib64 --with-libedit=shared,/usr --with-libxml-dir=/usr --with-libzip=/usr --with-mysql-sock=/var/lib/mysql/mysql.sock --with-mysqli=shared,mysqlnd --with-openssl=shared,/usr --with-pcre-jit --with-pcre-regex=/usr --with-pdo-mysql=shared,mysqlnd --with-pic --with-system-ciphers --with-system-tzdata --with-tidy=shared,/usr --with-zlib=shared --with-zlib-dir=/usr --disable-cgi --disable-dmalloc --disable-dtrace --disable-gcov --disable-gd-jis-conv --disable-ipv6 --disable-mysqlnd-compression-support --disable-opcache-file --disable-phpdbg --disable-rpath --disable-short-tags --disable-static --enable-gcc-global-regs --disable-debug
configure: WARNING: unrecognized options: --enable-bcmath, --enable-calendar, --enable-cli, --enable-ctype, --enable-dom, --enable-exif, --enable-fileinfo, --enable-filter, --enable-hash, --enable-huge-code-pages, --enable-intl, --enable-json, --enable-libxml, --enable-mbregex, --enable-mbstring, --enable-mysqlnd, --enable-opcache, --enable-pcntl, --enable-pdo, --enable-phar, --enable-posix, --enable-re2c-cgoto, --enable-session, --enable-simplexml, --enable-soap, --enable-sockets, --enable-tokenizer, --enable-xml, --enable-xmlreader, --enable-xmlwriter, --enable-zip, --with-apxs2, --with-bz2, --with-config-file-path, --with-config-file-scan-dir, --with-curl, --with-freetype-dir, --with-gd, --with-gettext, --with-iconv, --with-imap-ssl, --with-imap, --with-kerberos, --with-layout, --with-libdir, --with-libedit, --with-libxml-dir, --with-libzip, --with-mysql-sock, --with-mysqli, --with-openssl, --with-pcre-jit, --with-pcre-regex, --with-pdo-mysql, --with-system-ciphers, --with-system-tzdata, --with-tidy, --with-zlib, --with-zlib-dir, --disable-cgi, --disable-dmalloc, --disable-dtrace, --disable-gcov, --disable-gd-jis-conv, --disable-ipv6, --disable-mysqlnd-compression-support, --disable-opcache-file, --disable-phpdbg, --disable-rpath, --disable-short-tags, --disable-debug
./configure: line 2550: syntax error near unexpected token `config.nice'
./configure: line 2550: `PHP_CONFIG_NICE(config.nice)'
Fehler: Fehler-Status beim Beenden von /var/tmp/rpm-tmp.8ledcf (%build


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-11-08 18:40 UTC] spam2 at rhsoft dot net
the same for RC5 on Fedora 26 x86_64

./configure: line 2550: syntax error near unexpected token `config.nice'
./configure: line 2550: `PHP_CONFIG_NICE(config.nice)'
Fehler: Fehler-Status beim Beenden von /var/tmp/rpm-tmp.wThSHl (%build)

it's practically the same bullshit as https://bugs.php.net/bug.php?id=75115 that you need "touch configure.ac" for PHP7.2 and "touch configure.in" for any other version
 [2017-11-13 12:10 UTC] remi@php.net
-Status: Open +Status: Not a bug
 [2017-11-13 12:10 UTC] remi@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

Use rude wording is not going to help.

More, the switch to configure.ac was expected
 [2017-11-13 12:20 UTC] spam2 at rhsoft dot net
> the switch to configure.ac was expected

then do it globally, it's a joke that you need such constructs to build 7.0/7.1/snaphsots with the same rpm spec

# force use of system libtool and regenerate configure scripts
cat `aclocal --print-ac-dir`/{libtool,ltoptions,ltsugar,ltversion,lt~obsolete}.m4 >> aclocal.m4
libtoolize --force --copy --quiet
cat `aclocal --print-ac-dir`/{libtool,ltoptions,ltsugar,ltversion,lt~obsolete}.m4 >build/libtool.m4
%if "%{version}" >= "7.2.0"
touch configure.ac
%else
touch configure.in
%endif
./buildconf --force
 [2017-11-13 12:35 UTC] nikic@php.net
> then do it globally, it's a joke that you need such constructs to build 7.0/7.1/snaphsots with the same rpm spec

So let me get this straight. You are suggesting that, just because you are incapable of adjusting your build system for a new version of PHP, we should instead break the build automation for everyone else by performing such a change on a **STABLE** release?

Yeah, you are right, that's a good joke. Ha ha.
 [2017-11-14 12:03 UTC] spam2 at rhsoft dot net
the only joke to start with is that this hack to use system libtool is needed at all instead doing so as default and only fall back to bundeled stuff if not available
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Feb 24 12:01:25 2020 UTC