php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #75499 Test suite freezes sapi/phpdbg/tests/run_001.phpt
Submitted: 2017-11-08 09:33 UTC Modified: 2018-07-01 04:22 UTC
From: royopa@php.net Assigned: cmb (profile)
Status: No Feedback Package: phpdbg
PHP Version: master-Git-2017-11-08 (Git) OS: Linux Debian Jessie & Ubuntu1604
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: royopa@php.net
New email:
PHP Version: OS:

 

 [2017-11-08 09:33 UTC] royopa@php.net
Description:
------------
The test suite freezes without alert the user.

TEST 15540/15558 [sapi/phpdbg/tests/run_001.phpt]

https://github.com/php/php-src/pull/2894

Even though the parameter register_argc_argv is setted On, the problem continues.

/home/vagrant/phptestfest-php-src/sapi/phpdbg/phpdbg -qIb -n -c '/home/vagrant/phptestfest-php-src/tmp-php.ini' -d "output_handler=" -d "open_basedir=" -d "disable_functions=" -d "output_buffering=Off" -d "error_reporting=32767" -d "display_errors=1" -d "display_startup_errors=1" -d "log_errors=0" -d "html_errors=0" -d "track_errors=0" -d "report_memleaks=1" -d "report_zend_debug=0" -d "docref_root=" -d "docref_ext=.html" -d "error_prepend_string=" -d "error_append_string=" -d "auto_prepend_file=" -d "auto_append_file=" -d "ignore_repeated_errors=0" -d "precision=14" -d "memory_limit=128M" -d "log_errors_max_len=0" -d "opcache.fast_shutdown=0" -d "opcache.file_update_protection=0" -d "zend.assertions=1" -d "extension_dir=/home/vagrant/phptestfest-php-src/modules/" -d "zend_extension=/home/vagrant/phptestfest-php-src/modules/opcache.so" -d "session.auto_start=0" -d "zlib.output_compression=Off" -d "mbstring.func_overload=0" -d "opcache.enable_cli=0" -d "register_argc_argv=On" -f "/home/vagrant/phptestfest-php-src/sapi/phpdbg/tests/run_001.php" -- 1 2 3
2>&1

Is it a bug in PHPDBG?

Test script:
---------------
sapi/phpdbg/tests/run_001.phpt

Actual result:
--------------
The test suites freezes

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-06-23 14:37 UTC] cmb@php.net
-Status: Open +Status: Feedback -Assigned To: +Assigned To: cmb
 [2018-06-23 14:37 UTC] cmb@php.net
> The test suites freezes

Do you mean that you don't get phpdbg's prompt?  Anyhow, what
happens if you run

  make test TESTS=sapi/phpdbg/tests/run_001.phpt
 [2018-07-01 04:22 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Fri Sep 22 16:01:24 2023 UTC