php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #75456 Native Hijri Calendar support
Submitted: 2017-10-29 23:55 UTC Modified: 2017-10-30 10:33 UTC
From: haneef95 at gmail dot com Assigned: cmb (profile)
Status: Duplicate Package: Calendar related
PHP Version: 7.0.25 OS: Cent OS
Private report: No CVE-ID: None
 [2017-10-29 23:55 UTC] haneef95 at gmail dot com
Description:
------------
There should be native support for a calendar as widely used as the Umm al-Qura Hijri calendar. I cannot see the support here, hence, I presume it is not available: http://php.net/manual/en/ref.calendar.php

There are external libraries, but, a native support would be good:
https://www.phpclasses.org/browse/file/43092.html

We should be able to convert between; Greg, Hijri, Julian, UnixTime calendars.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-10-30 00:51 UTC] haneef95 at gmail dot com
(Microsoft Windows supports Hijri calendar naively)[https://www.microsoft.com/middleeast/msdn/ArabicCalendar.aspx]
(Microsoft Office has native support)[https://blogs.technet.microsoft.com/office_global_experience/2010/01/13/um-al-qura-calendar-support-in-office-2010/]
(Apple supports the Hijri calendar in 5 of their SDKs (Software Development Kits))[https://developer.apple.com/documentation/foundation/calendar.identifier]
(Android Hijri calendar support)[https://developer.android.com/reference/android/icu/util/IslamicCalendar.html]
(Java Hijri calendar support)[https://docs.oracle.com/javase/8/docs/api/java/time/chrono/HijrahChronology.html]
(Google Calendar allows Hijri calendar as an alternate calendar)[https://www.maketecheasier.com/display-alternate-calendar-google-calendar/]
 [2017-10-30 10:33 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Package: *General Issues +Package: Calendar related -Assigned To: +Assigned To: cmb
 [2017-10-30 10:33 UTC] cmb@php.net
This is a duplicate of bug #27453.

Adding this feature would require the RFC process; see the other
ticket for details.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Fri Dec 14 11:01:26 2018 UTC