php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #75345 Strict type declarations not enforced for Reflection API invocation
Submitted: 2017-10-09 14:42 UTC Modified: 2018-07-02 18:22 UTC
Votes:5
Avg. Score:4.0 ± 0.9
Reproduced:3 of 5 (60.0%)
Same Version:2 (66.7%)
Same OS:2 (66.7%)
From: sebastian@php.net Assigned:
Status: Wont fix Package: Reflection related
PHP Version: Irrelevant OS: Irrelevant
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2017-10-09 14:42 UTC] sebastian@php.net
Description:
------------
Strict type declarations are not enforced when a function or method is invoked via the Reflection API.

The test script generates the same result with PHP 7.0.25-dev (f48abfa9022c026c2447b14bc03c978d2b831b27), 7.1.11-dev (d8881f4eb4ec138db00d5fcf0b27a64f8986cd85), PHP 7.2.0-dev (611d117b24b58544ef69390cfe44166ba606b0ab), and PHP 7.3.0-dev (39ded1d5f85ca3358cc8a52bb37e72a5eb5ce0db).

Test script:
---------------
<?php
declare(strict_types=1);

function f(bool $a)
{
    var_dump($a);
}

$f = new ReflectionFunction('f');
$f->invokeArgs([1]); // or $f->invoke(1);

Expected result:
----------------
TypeError exception because int(1) does not match bool.

Actual result:
--------------
bool(true)

Patches

Add a Patch

Pull Requests

Pull requests:

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-07-02 18:22 UTC] nikic@php.net
-Status: Open +Status: Wont fix
 [2018-07-02 18:22 UTC] nikic@php.net
This has been discussed on the internals list in https://externals.io/message/100851, and the decision was not change this behavior.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Wed Dec 12 04:01:25 2018 UTC