php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #75285 Broken build when system libpcre don't have jit support
Submitted: 2017-09-29 12:55 UTC Modified: 2017-11-15 15:05 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: remi@php.net Assigned: remi (profile)
Status: Closed Package: PCRE related
PHP Version: 7.2.0RC3 OS:
Private report: No CVE-ID: None
 [2017-09-29 12:55 UTC] remi@php.net
Description:
------------
pcre system library can be build without jit support, which may be required on some arch.

Example in fedora

%ifarch s390 s390x sparc64 sparcv9 riscv64
    --disable-jit \
%else
    --enable-jit \
%endif

So, on these arches:
ext/pcre/.libs/php_pcre.o: In function `php_pcre_replace_func_impl':
/builddir/build/BUILD/php-7.2.0RC3/ext/pcre/php_pcre.c:1593: undefined reference to `pcre_jit_exec'



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-09-29 13:11 UTC] remi@php.net
-Assigned To: +Assigned To: remi
 [2017-09-29 13:50 UTC] remi@php.net
Automatic comment on behalf of remi
Revision: http://git.php.net/?p=php-src.git;a=commit;h=7c8357929cc3e0cabcb312c3fae48f6fb949944e
Log: Fixed bug #75285i Broken build when system libpcre don't have jit support
 [2017-11-15 15:05 UTC] remi@php.net
-Status: Assigned +Status: Closed
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC