php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #75243 PHP documentation should be mirrored on GitHub and editable via pull requests
Submitted: 2017-09-21 23:28 UTC Modified: 2020-02-02 19:21 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: peterkokot at gmail dot com Assigned: heiglandreas (profile)
Status: Not a bug Package: Online Doc Editor problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2017-09-21 23:28 UTC] peterkokot at gmail dot com
Description:
------------
PHP documentation files should be available also on GitHub and editable via pull requests.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-10-29 10:39 UTC] miika dot s dot koskela at gmail dot com
It would be easier to contribute to the docs if it were at Github. Also, something similar to Read the Docs (https://readthedocs.org/) would be good.

Using this kind of platform for docs could also reduce maintenance burden, right?

Regards, Miika
 [2018-07-15 23:32 UTC] carusogabriel@php.net
-Type: Documentation Problem +Type: Feature/Change Request -Package: Documentation problem +Package: Online Doc Editor problem
 [2018-07-16 12:51 UTC] kalle@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: heiglandreas
 [2018-07-16 12:51 UTC] kalle@php.net
Andreas is working on the SVN > Git migration, I'm not sure if there is other open reports for the matter else this could be a ticket to track progress.
 [2019-02-18 02:44 UTC] carusogabriel@php.net
For the record, we had some progress. Check the https://github.com/phpdoctest organization.
 [2019-05-20 11:00 UTC] petk@php.net
Thank you so much for someone working on this. Looking forward for having the Git repo. Is there any progress here? Can't we just turn the translations to a different workflow if they really cause so much issues with this?
 [2020-02-02 19:21 UTC] yannick@php.net
-Status: Assigned +Status: Not a bug
 [2020-02-02 19:21 UTC] yannick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Mar 01 05:01:29 2024 UTC