php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #75205 Bugs reports from automatic testing
Submitted: 2017-09-14 02:24 UTC Modified: 2020-10-04 04:24 UTC
Votes:2
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: ecamy at 163 dot com Assigned:
Status: Not a bug Package: Testing related
PHP Version: 5.6.31 OS: CentOS6.6
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ecamy at 163 dot com
New email:
PHP Version: OS:

 

 [2017-09-14 02:24 UTC] ecamy at 163 dot com
Description:
------------
When I installed the php5.6 on CentOS by compiling, it reports some bugs as attached. I can't deal with it because the hit of its is not enough. Would you help me? 


Patches

Bugsreport (last revision 2017-09-14 02:26 UTC by ecamy at 163 dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-09-14 15:02 UTC] cmb@php.net
-Package: *General Issues +Package: Testing related
 [2017-09-14 15:02 UTC] cmb@php.net
On a cursory glance it looks like you have not been online while
running the tests, in which case they have not been supposed to be
run at all.
 [2017-09-15 05:23 UTC] ecamy at 163 dot com
Yes, I installed all package by the way of offline. Even it can't pass during making test, but it still work well after making install. I don't know how about it can be in the future. Thanks so much for your reply.
 [2018-08-05 20:15 UTC] carusogabriel@php.net
All reported tests have a SKIPIF section for online tests:

    if (getenv("SKIP_ONLINE_TESTS")) die("skip online test");

But, this is only set if we pass `--offline` to `run-tests.php`.

What can be done, is set this `SKIP_ONLINE_TESTS` env var dynamically, checking for real internet connection.
 [2020-09-23 15:47 UTC] cmb@php.net
-Status: Open +Status: Feedback -Assigned To: +Assigned To: cmb
 [2020-09-23 15:47 UTC] cmb@php.net
Anyhow, I think this ticket can be closed now, can't it?
 [2020-10-04 04:22 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 [2020-10-04 04:24 UTC] requinix@php.net
-Status: No Feedback +Status: Not a bug -Assigned To: cmb +Assigned To:
 [2020-10-04 04:24 UTC] requinix@php.net
> But, this is only set if we pass `--offline` to `run-tests.php`.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Oct 29 06:01:25 2020 UTC