php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #75203 FILE_USE_INCLUDE_PATH: INT instead BOOL.
Submitted: 2017-09-13 17:11 UTC Modified: 2017-09-19 15:05 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: saymongcsw at gmail dot com Assigned: cmb (profile)
Status: Closed Package: Filesystem function related
PHP Version: 7.1.9 OS: any
Private report: No CVE-ID: None
 [2017-09-13 17:11 UTC] saymongcsw at gmail dot com
Description:
------------
FILE_USE_INCLUDE_PATH returns 1 instead true. https://3v4l.org/UqBVt
what causes error with strict_types=1 in file_get_contents().

Test script:
---------------
<?php
declare(strict_types = 1);

file_get_contents('example.txt', FILE_USE_INCLUDE_PATH);

Expected result:
----------------
load contents successfully.

Actual result:
--------------
file_get_contents() expects parameter 2 to be boolean, integer given

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-09-13 23:09 UTC] cmb@php.net
-Status: Open +Status: Verified
 [2017-09-13 23:09 UTC] cmb@php.net
To fix this FILE_USE_INCLUDE_PATH would have to be registered via
REGISTER_BOOL_CONSTANT[1]. I'm not sure about the potential BC
break, though.

[1] <https://github.com/php/php-src/blob/PHP-7.0.23/ext/standard/file.c#L302>
 [2017-09-13 23:12 UTC] cmb@php.net
-Package: *General Issues +Package: Filesystem function related
 [2017-09-18 18:56 UTC] saymongcsw at gmail dot com
https://3v4l.org/2Uvu1 another example.
 [2017-09-19 14:32 UTC] cmb@php.net
-Assigned To: +Assigned To: cmb
 [2017-09-19 14:32 UTC] cmb@php.net
Actually, we can't change FILE_USE_INCLUDE_PATH to bool, because it is an
accepted flag for the $flags parameter of file_put_contents() (which is an int).
Changing the $use_include_path parameter of file_get_contents() to int is also
not an option. Therefore the documentation will have to be fixed.
 [2017-09-19 14:32 UTC] cmb@php.net
-Type: Bug +Type: Documentation Problem
 [2017-09-19 15:04 UTC] cmb@php.net
Automatic comment from SVN on behalf of cmb
Revision: http://svn.php.net/viewvc/?view=revision&amp;revision=343110
Log: Fix #75203: FILE_USE_INCLUDE_PATH: INT instead BOOL
 [2017-09-19 15:05 UTC] cmb@php.net
-Status: Verified +Status: Closed
 [2017-09-19 15:05 UTC] cmb@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC