|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #75142 check for autoconf version needs to be updated for v2.64
Submitted: 2017-08-31 23:10 UTC Modified: 2017-09-05 06:21 UTC
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: zizzy at zizzy dot net Assigned: remi (profile)
Status: Closed Package: Compile Failure
PHP Version: 7.2.0RC1 OS: CentOS 6.9
Private report: No CVE-ID: None
 [2017-08-31 23:10 UTC] zizzy at zizzy dot net
------------ currently says "OK" when verifying the installed autoconf version, if autoconf is v2.59 or older. PHP 7.2 will not build unless autoconf is v2.64 or newer.

CentOS v6.9 with all updates has autoconf v2.63, which works fine on PHP v7.1. With PHP v7.2, autoconf must be manually updated to v2.69 before PHP 7.2 will build.


buildcheck_php7.2rc0.patch (last revision 2017-08-31 23:11 UTC) by zizzy at zizzy dot net)

Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2017-08-31 23:12 UTC] zizzy at zizzy dot net
Typo says "OK" if autoconf is v2.59 or NEWER, not older.
 [2017-09-01 13:04 UTC]
-Type: Documentation Problem +Type: Bug
 [2017-09-05 06:02 UTC]
Indeed, new version included ax_check_compile_flag.m4 which have

 [2017-09-05 06:20 UTC]
Automatic comment on behalf of remi
Log: Fixed bug #75142 check for autoconf version needs to be updated for v2.64
 [2017-09-05 06:20 UTC]
-Status: Open +Status: Closed
 [2017-09-05 06:21 UTC]
-Assigned To: +Assigned To: remi
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC