php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #75057 php-fpm -t doesn't verify does user exist
Submitted: 2017-08-10 06:50 UTC Modified: 2021-12-04 21:29 UTC
Votes:7
Avg. Score:4.7 ± 0.7
Reproduced:5 of 5 (100.0%)
Same Version:2 (40.0%)
Same OS:4 (80.0%)
From: hubert dot nodzak at vml dot com Assigned:
Status: Duplicate Package: FPM related
PHP Version: Irrelevant OS: Centos 7 x64
Private report: No CVE-ID: None
 [2017-08-10 06:50 UTC] hubert dot nodzak at vml dot com
Description:
------------
php-fpm -t command doesn't verify does user provided in pool config exist in system. So, php-fpm -t may report no errors, but after restart reload php-fpm will not run.


Test script:
---------------
php-fpm -t
systemctl restart php-fpm


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-12-04 21:29 UTC] bukka@php.net
-Status: Open +Status: Duplicate
 [2021-12-04 21:29 UTC] bukka@php.net
Duplicate of https://bugs.php.net/bug.php?id=68591
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jul 06 10:03:41 2022 UTC