php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #74990 pcntl_fork do not exit
Submitted: 2017-07-26 03:34 UTC Modified: 2017-07-26 10:23 UTC
From: xltxlm at qq dot com Assigned:
Status: Not a bug Package: PCNTL related
PHP Version: 7.1.7 OS: Debian GNU/Linux 8 on docker
Private report: No CVE-ID: None
 [2017-07-26 03:34 UTC] xltxlm at qq dot com
Description:
------------
the test code run ok less than php 7.1.6 .

error on php 7.1.7

Test script:
---------------
$i = 0;
while ($i++ < 3) {
    $pid = pcntl_fork(); //创建子进程
    if ($pid == 0) {
        echo "$i.";
        sleep(1);
        exit;
    }
    pcntl_wait($status);
}

Expected result:
----------------
1.2.3.

Actual result:
--------------
1.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-07-26 05:12 UTC] xltxlm at qq dot com
i'm sorry. it is not php 7.1.7's error.

it error because  grpc.so .
 [2017-07-26 10:23 UTC] laruence@php.net
-Status: Open +Status: Not a bug
 [2017-07-26 10:23 UTC] laruence@php.net
close as comment
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Nov 29 11:03:18 2021 UTC