php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #74987 Registry keys no longer valid
Submitted: 2017-07-25 11:38 UTC Modified: 2017-09-21 17:16 UTC
Votes:1
Avg. Score:1.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: johannes dot kingma at gmail dot com Assigned: cmb (profile)
Status: Closed Package: PHP options/info functions
PHP Version: 7.2Git-2017-07-25 (Git) OS: Windows 10
Private report: No CVE-ID: None
 [2017-07-25 11:38 UTC] johannes dot kingma at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/configuration.file
---
Bullet 3 should read:

As of PHP 5.2.0, the location of the php.ini file can be set for different versions of PHP. The following registry keys are examined in order: [HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\PHP\x.y.z], [HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\PHP\x.y] and [HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\PHP\x], where x, y and z mean the PHP major, minor and release versions. If there is a value for IniFilePath in any of these keys, the first one found will be used as the location of the php.ini (Windows only).
[HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\PHP], value of IniFilePath (Windows only). 

Summery:
Keys for 32bit binaries are stored under HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\
Keys for 64bit binaries are stored under HKEY_LOCAL_MACHINE\SOFTWARE\

Test script:
---------------
<?php echo phpinfo(1);

Expected result:
----------------
Loaded Configuration File shows the file that is loaded.


Patches

patch-1501670016 (last revision 2017-08-02 15:03 UTC) by johannes dot kingma at gmail dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-07-31 11:49 UTC] ab@php.net
Thanks for the report. Would you be up to send a doc patch?

Thanks.
 [2017-09-21 17:03 UTC] cmb@php.net
-Assigned To: +Assigned To: cmb
 [2017-09-21 17:03 UTC] cmb@php.net
Thanks for the report and the patch (very much appreciated)!
 [2017-09-21 17:15 UTC] cmb@php.net
Automatic comment from SVN on behalf of cmb
Revision: http://svn.php.net/viewvc/?view=revision&amp;revision=343127
Log: Fix #74987: Registry keys no longer valid

Patch provided by johannes.kingma
 [2017-09-21 17:16 UTC] cmb@php.net
-Status: Assigned +Status: Closed
 [2017-09-21 17:16 UTC] cmb@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC