php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #74893 SCRIPT_NAME and PHP_SELF incorrectly set
Submitted: 2017-07-10 17:50 UTC Modified: 2017-07-11 08:36 UTC
Votes:3
Avg. Score:3.3 ± 1.7
Reproduced:2 of 3 (66.7%)
Same Version:1 (50.0%)
Same OS:2 (100.0%)
From: php at webstyle dot ch Assigned:
Status: Not a bug Package: FPM related
PHP Version: 5.6.31 OS: FreeBSD 10.3
Private report: No CVE-ID: None
 [2017-07-10 17:50 UTC] php at webstyle dot ch
Description:
------------
Under 5.6.31's (and 7.0.21's) FPM, SCRIPT_NAME and PHP_SELF are incorrectly set to "/index.php" rather than "/admin/phpinfo/index.php". Under mod_fcgid or 5.6.30/7.0.21 it properly works. SCRIPT_FILENAME is still properly set, also under the newest FPM.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-07-11 08:20 UTC] php at webstyle dot ch
-Status: Open +Status: Closed
 [2017-07-11 08:20 UTC] php at webstyle dot ch
Please do no longer mind. It's indeed an Apache 2.4.26 Bug: https://bz.apache.org/bugzilla/show_bug.cgi?id=61202
 [2017-07-11 08:36 UTC] requinix@php.net
-Status: Closed +Status: Not a bug
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Tue Sep 25 07:01:25 2018 UTC