php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7486 imap_uid does not return the uid
Submitted: 2000-10-27 03:30 UTC Modified: 2001-05-03 17:16 UTC
From: rick at alpinenetworking dot com Assigned:
Status: Not a bug Package: IMAP related
PHP Version: 4.0.2 OS: Red Hat Linux
Private report: No CVE-ID: None
 [2000-10-27 03:30 UTC] rick at alpinenetworking dot com
When I call connect to a qmail pop server and call imap_uid all it does is return the message number back to me.  It DOES NOT return the uid.  I have to call imap_header for that and it is very slow.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-03 15:36 UTC] chagenbu@php.net
You might have the wrong idea of what uid is - what do you expect it to be? On pop servers the message uid will very likely just _be_ the message number...
 [2001-05-03 17:14 UTC] chagenbu@php.net
From: "Rick Gigger" <rick@alpinenetworking.com>

All email messages have a unique identifier.  It is a long string that ususally contains a domiain name or ip address.  It is unique to all email addresses in the world.  It would be much, much more useful if imap_uid
would return that instead.
 [2001-05-03 17:16 UTC] chagenbu@php.net
That's the Message-ID header. The uid which imap_uid() is intended to return is a unique identifier of that that message in that mailbox that won't change over time. It has nothing to do with the Message-ID header.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Jul 18 11:01:25 2019 UTC