php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #74825 missing file error installing via pecl
Submitted: 2017-06-28 19:54 UTC Modified: 2017-06-29 16:40 UTC
From: ryan dot brothers at gmail dot com Assigned:
Status: Duplicate Package: ssh2 (PECL)
PHP Version: 7.1.6 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ryan dot brothers at gmail dot com
New email:
PHP Version: OS:

 

 [2017-06-28 19:54 UTC] ryan dot brothers at gmail dot com
Description:
------------
When trying to upgrade to ssh2 1.1.1 via pecl, I'm getting an error about a missing file tests/ssh2_auth.phpt.

Test script:
---------------
pecl upgrade ssh2


Expected result:
----------------
ssh2 compiles and installs

Actual result:
--------------
downloading ssh2-1.1.1.tgz ...
Starting to download ssh2-1.1.1.tgz (27,551 bytes)
.....done: 27,551 bytes
ERROR: file /tmp/pear/temp/tmpkUSNGF/ssh2-1.1.1/tests/ssh2_auth.phpt does not exist


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-06-29 16:40 UTC] yunosh@php.net
-Status: Open +Status: Duplicate
 [2017-06-29 16:40 UTC] yunosh@php.net
Duplicate of bug #74787
 [2017-07-12 03:35 UTC] dean at deanlofts dot xyz
I also get this issue.

root@Lofts:/srv/users/serverpilot/apps/shakedown# sudo pecl7.0-sp install ssh2-alpha
WARNING: channel "pecl.php.net" has updated its protocols, use "pecl channel-update pecl.php.net" to update
downloading ssh2-1.1.1.tgz ...
Starting to download ssh2-1.1.1.tgz (27,551 bytes)
.........done: 27,551 bytes
ERROR: file /tmp/pear/temp/tmpTPaWq1/ssh2-1.1.1/tests/ssh2_auth.phpt does not exist
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Apr 11 20:01:27 2021 UTC