php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #74759 PS won't compile with PHP7
Submitted: 2017-06-14 13:34 UTC Modified: 2017-06-14 14:29 UTC
From: w dot verleger at proio dot com Assigned: cmb (profile)
Status: Duplicate Package: ps (PECL)
PHP Version: 7.0.20 OS: CentOS 7.3.1611
Private report: No CVE-ID: None
 [2017-06-14 13:34 UTC] w dot verleger at proio dot com
Description:
------------
Using PECL or trying MAKE (manually):

/bin/sh /root/ps-1.4.0/libtool --mode=compile cc  -I. -I/root/ps-1.4.0 -DPHP_ATOM_INC -I/root/ps-1.4.0/include -I/root/ps-1.4.0/main -I/root/ps-1.4.0 -I/usr/include/php -I/usr/include/php/main -I/usr/include/php/TSRM -I/usr/include/php/Zend -I/usr/include/php/ext -I/usr/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /root/ps-1.4.0/ps.c -o ps.lo
libtool: compile:  cc -I. -I/root/ps-1.4.0 -DPHP_ATOM_INC -I/root/ps-1.4.0/include -I/root/ps-1.4.0/main -I/root/ps-1.4.0 -I/usr/include/php -I/usr/include/php/main -I/usr/include/php/TSRM -I/usr/include/php/Zend -I/usr/include/php/ext -I/usr/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /root/ps-1.4.0/ps.c  -fPIC -DPIC -o .libs/ps.o
/root/ps-1.4.0/ps.c: In function 'zif_ps_open_memory_image':
/root/ps-1.4.0/ps.c:1345:2: warning: 'zend_get_parameters_ex' is deprecated (declared at /usr/include/php/Zend/zend_API.h:249) [-Wdeprecated-declarations]
  if (ZEND_NUM_ARGS() != 2 || zend_get_parameters_ex(2, &arg1, &arg2) == FAILURE) {
  ^
In file included from /usr/include/php/Zend/zend.h:31:0,
                 from /usr/include/php/main/php.h:35,
                 from /root/ps-1.4.0/ps.c:25:
/usr/include/php/Zend/zend_types.h:551:31: error: request for member 'value' in something not a structure or union
 #define Z_RES(zval)     (zval).value.res
                               ^
/usr/include/php/Zend/zend_types.h:552:28: note: in expansion of macro 'Z_RES'
 #define Z_RES_P(zval_p)    Z_RES(*zval_p)
                            ^
/root/ps-1.4.0/ps.c:1350:42: note: in expansion of macro 'Z_RES_P'
  if ((ps = (PSDoc *) zend_fetch_resource(Z_RES_P(arg1), "ps document", le_psdoc)) == NULL) { RETURN_FALSE; }
                                          ^
/usr/include/php/Zend/zend_types.h:551:31: error: request for member 'value' in something not a structure or union
 #define Z_RES(zval)     (zval).value.res
                               ^
/usr/include/php/Zend/zend_types.h:552:28: note: in expansion of macro 'Z_RES'
 #define Z_RES_P(zval_p)    Z_RES(*zval_p)
                            ^
/root/ps-1.4.0/ps.c:1356:45: note: in expansion of macro 'Z_RES_P'
  if ((im = (gdImagePtr) zend_fetch_resource(Z_RES_P(arg2), "Image", le_gd)) == NULL) { RETURN_FALSE; }
                                             ^
make: *** [ps.lo] Error 1


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-06-14 14:29 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2017-06-14 14:29 UTC] cmb@php.net
Basically, this is a duplicate of bug #71801.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Jun 27 06:01:31 2019 UTC