php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #74746 Adjust ZEND_EXTENSION_API_NO
Submitted: 2017-06-12 00:16 UTC Modified: 2017-06-13 20:04 UTC
From: rainer dot jung at kippdata dot de Assigned: cmb (profile)
Status: Closed Package: *General Issues
PHP Version: 7.2.0alpha1 OS: Any
Private report: No CVE-ID: None
 [2017-06-12 00:16 UTC] rainer dot jung at kippdata dot de
Description:
------------
Last releases updated ZEND_EXTENSION_API_NO, ZEND_MODULE_API_NO and PHP_API_VERSION in sync.

Version 7.2.0alpha1 only updated ZEND_MODULE_API_NO and PHP_API_VERSION to "20160731", but ZEND_EXTENSION_API_NO is still at 320160303 (same value as for 7.1).

I do not know the exact rules, but previous handling indicates it should be updated to 320160731.

Regards and thanks.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-06-12 10:32 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2017-06-12 10:32 UTC] cmb@php.net
That appears to be a duplicate of bug #74735.
 [2017-06-12 11:10 UTC] rainer dot jung at kippdata dot de
Yes it is kind of duplicate of bug #74735, but note that the PR cited there is about ZEND_MODULE_API_NO which was updated in the meantime. What is still at the old level is ZEND_EXTENSION_API_NO.
 [2017-06-12 12:23 UTC] cmb@php.net
-Status: Duplicate +Status: Re-Opened -Assigned To: cmb +Assigned To:
 [2017-06-12 12:23 UTC] cmb@php.net
> […], but note that the PR cited there is about
> ZEND_MODULE_API_NO which was updated in the meantime.

It doesn't appear to have been updated, see
<https://github.com/php/php-src/blob/master/Zend/zend_modules.h#L36>

Anyhow, re-opening so updating ZEND_EXTENSION_API_NO won't get overlooked.
 [2017-06-13 19:11 UTC] kalle@php.net
-Assigned To: +Assigned To: cmb
 [2017-06-13 19:11 UTC] kalle@php.net
It seems that it was fixed in 586a22cbadf3d1e37524b53b6436abbb3fbe105f So this can be closed, right Christoph?
 [2017-06-13 19:59 UTC] rainer dot jung at kippdata dot de
586a22cbadf3d1e37524b53b6436abbb3fbe105f updated ZEND_MODULE_API_NO but *not* ZEND_EXTENSION_API_NO. See my original problem description.
 [2017-06-13 20:04 UTC] nikic@php.net
ZEND_EXTENSION_API_NO has already been updated previously...
 [2017-06-13 20:04 UTC] nikic@php.net
-Status: Re-Opened +Status: Closed
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Sep 23 23:01:23 2020 UTC