php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #74676 Document unsupported extensions?
Submitted: 2017-05-30 20:29 UTC Modified: 2017-05-30 21:44 UTC
From: ian at gumstix dot com Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: Irrelevant OS: N/A
Private report: No CVE-ID: None
 [2017-05-30 20:29 UTC] ian at gumstix dot com
Description:
------------
The Postscript (ps) extension does not work in PHP7 and never has:

https://bugs.php.net/bug.php?id=74124

But you wouldn't know it from reading the manual:

http://php.net/manual/en/book.ps.php

As far as I can tell, this extension was never deprecated, but it clearly was not considered a blocking issue for the release of PHP7.

How can I tell which PECL extensions are actually supported, and which (like ps) are effectively not?


Patches

9.79.0-75f6630 (last revision 2017-10-14 06:23 UTC by jerrie dot coleman013173 at gmail dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-05-30 21:09 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2017-05-30 21:09 UTC] requinix@php.net
1. The ps changelog specifically mentions that 1.4.0 supports PHP 7 ("phpng") and no longer supports PHP 5. Even Linux distros are bundling ps-1.4.0 with their PHP 7 builds.
2. If ps didn't support PHP 7 at all then you wouldn't even be able to use the extension because PHP would have ignored it during startup. With a warning.

I don't even see anything in your backtrace to suggest ps is at fault: the crash is happening while opcache is compiling a file during an autoload.
 [2017-05-30 21:19 UTC] ian at gumstix dot com
Thank you for replying so quickly!

Is bug 74124 a bug in the PHP core, then? (Forgive my ignorance of PHP internals.)

It seems to me that a segfault is a bug in PHP itself -- if there's a bug in my code, PHP should politely tell me. Is that true, or are there cases where a segfault is my (the PHP programmer's) responsibility?
 [2017-05-30 21:44 UTC] requinix@php.net
Rule of thumb is that PHP shouldn't segfault due to a problem with userland code, but there are occasional exceptions (eg, some instances of infinite recursion). Your problem doesn't look like one that I recognize.
 [2017-05-30 22:06 UTC] ian at gumstix dot com
Thank you for your help! I've updated bug 74124 accordingly.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Nov 15 17:01:42 2019 UTC