php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #74650 When navigating back in the browser, the selected language is cached
Submitted: 2017-05-25 02:59 UTC Modified: 2017-05-25 15:54 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 1 (0.0%)
From: lexrulezzz at mail dot ru Assigned:
Status: Not a bug Package: Website problem
PHP Version: Irrelevant OS: Linux
Private report: No CVE-ID: None
 [2017-05-25 02:59 UTC] lexrulezzz at mail dot ru
Description:
------------
Steps to reproduce the problem:

1. Go to the documentation page, for example - http://php.net/manual/en/migration70.incompatible.php
2. Select a different language from the select list of languages, for example, Russian (http://php.net/manual/ru/migration70.incompatible.php)
3. Use the "Back" button in the browser to go to the previous page

Actual result
In the select list, the Russian language will be selected (see screenshot http://joxi.ru/12MWvQ3sMGbBlr), although the third step was to go to the documentation page in English.

Expected Result
The English language will be selected in the select list.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-05-25 07:55 UTC] danack@php.net
-Status: Open +Status: Not a bug
 [2017-05-25 07:55 UTC] danack@php.net
That is how HTML input elements work, at least in Chrome.

When pressing back, instead of resetting the form to how it was originally, the browser remembers the last state it had.
 [2017-05-25 15:54 UTC] lexrulezzz at mail dot ru
Okay, but you can fix it, right? Now this is a problem, it's good to fix it.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Dec 08 05:05:52 2022 UTC