php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #74616 Apache closes connection on imagick functions calls after long time
Submitted: 2017-05-18 20:13 UTC Modified: -
Votes:4
Avg. Score:3.5 ± 1.7
Reproduced:4 of 4 (100.0%)
Same Version:3 (75.0%)
Same OS:1 (25.0%)
From: info at ihead dot ru Assigned:
Status: Open Package: imagick (PECL)
PHP Version: 7.0.19 OS: FreeBSD 9,10
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2017-05-18 20:13 UTC] info at ihead dot ru
Description:
------------
I found a strange behavior.
Apache (mod_php) closes connection if there are any imagick functions calls (Wordpress image upload or simple phpinfo). This happens after, for example, 100 days of uptime.

Following messages appear in log on any hit:

Magick: Memory allocation failed `No such file or directory' @ fatal/tiff.c/RegisterTIFFImage/2252.
unable to lock mutex: Resource deadlock avoided

Only full stop and start of Apache helps to run normal again.

Apache 2.4.25
PHP 7.0.14, 7.0.16 and others 7.0.* before.
ImageMagick-6.9.6.4
imagick 3.4.3

Test script:
---------------
<?
phpinfo()


Expected result:
----------------
work normal

Actual result:
--------------
Apache closes connection.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-05-26 10:26 UTC] danack@php.net
This will almost certainly be a problem internal to ImageMagick, rather than one caused by the PHP extension.

Please could you open this issue upstream at https://github.com/ImageMagick/ImageMagick
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Aug 21 20:01:27 2019 UTC