php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #74537 Remove the need to specify version number in the PDO_OCI configure option
Submitted: 2017-05-04 06:27 UTC Modified: 2017-05-08 00:48 UTC
From: tianfang dot yang at oracle dot com Assigned: sixd (profile)
Status: Closed Package: PDO OCI
PHP Version: 7.1.4 OS:
Private report: No CVE-ID: None
 [2017-05-04 06:27 UTC] tianfang dot yang at oracle dot com
Description:
------------
PDO OCI doesn't support Oralce instantclient 12.2 yet. So config.m4 needs to 
be edited to remove the need to specify version number in the configure
option.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-05-08 00:48 UTC] sixd@php.net
-Summary: Remove the need to specify version number in the configure option +Summary: Remove the need to specify version number in the PDO_OCI configure option -Assigned To: +Assigned To: sixd
 [2017-05-08 00:48 UTC] sixd@php.net
Ideally PDO_OCI's .m4 would be similar to OCI8's, and not require a version number at the end.

For current production PDO_OCI config.m4's it will be less destabilizing to just allow 12.2 in the configure option.

The user workaround is to use the number 12.1 in the configure option when building with 12.2 libraries: --with-pdo-oci=instantclient,/whereever/instantclient_12_2,12.1
 [2017-06-20 06:24 UTC] sixd@php.net
Automatic comment on behalf of sixd
Revision: http://git.php.net/?p=php-src.git;a=commit;h=52e5406e875b98db91b8fdd071b44c84d681e685
Log: Fixed Bug #74537 (Align --with-pdo-oci configure option with --with-oci8 syntax)
 [2017-06-20 06:24 UTC] sixd@php.net
-Status: Assigned +Status: Closed
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC