php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7451 thttpd 2.20b and php4.0.3pl1, php.ini isn't read
Submitted: 2000-10-25 11:26 UTC Modified: 2001-04-02 12:54 UTC
From: donncha dot ocaoimh at tradesignals dot com Assigned:
Status: Closed Package: Other web server
PHP Version: 4.0.3pl1 OS: Linux, RH 6.1
Private report: No CVE-ID: None
 [2000-10-25 11:26 UTC] donncha dot ocaoimh at tradesignals dot com
I installed thttpd 2.20b with PHP-4.0.3pl1
I also tried thttpd 2.19 as well with the same result.

Bringing up a page with phpinfo() showed that all settings in php.ini were being ignored. The include path is set to ".:/usr/local/lib/php" even though it's completely different in php.ini
phpinfo() gives "/usr/local/lib" as the directory holding php.ini which is correct.

PHP configure line was 
'./configure' '--enable-memory-limit' '--disable-debug' '--enable-sysvshm' '--enable-sysvsem' '--with-mysql=/usr/local' '--without-gd' '--with-zlib' '--with-thttpd=../thttpd-2.19'

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-04-02 12:54 UTC] sniper@php.net
Tried with latest CVS and it works just fine.
Please try the snapshot from http://snaps.php.net/
and if it doesn't work for you, reopen this bug report.

--Jani

 [2003-02-21 11:44 UTC] wenyis at promise dot com
I see the same problem with phpinfo(). Settings in php.ini are not been used.

I use thttpd-2.21b and php-4.3.1. Here is what I have done:
cd php-4.3.1
./configure --prefix=/home/wenyis/php4 --without-mysql \
    --with-thttpd=/home/wenyis/thttpd-2.21b --disable-cli \
    --with-config-file-path=/home/wenyis/php4/lib
make
make install
cd ../thttpd-2.21b
./configure
make
./thttpd -D -C config

Here is the content is my 'config' file:
dir=/home/wenyis/www/public
chroot
phppat=**.php
phpspat=**.php
logfile=/home/wenyis/www/public/logs

Then I load my index.php file with phpinfo(). The 'Configuration File (php.ini) Path' is shown as '/home/wenyis/php4/lib'. My settings in the php.ini are not shown.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Aug 07 12:01:24 2020 UTC