php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #74359 WARNING: [pool websit] child 9297 exited on signal 7 (SIGBUS - core dumped) aft
Submitted: 2017-04-01 10:28 UTC Modified: 2017-12-23 11:08 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: sterngre at gmail dot com Assigned:
Status: Duplicate Package: Reproducible crash
PHP Version: 5.6.30 OS: CentOS Linux release 7.3.1611 (C
Private report: No CVE-ID: None
 [2017-04-01 10:28 UTC] sterngre at gmail dot com
Description:
------------
Hello

I`m getting random failurs of PHP with 
WARNING: [pool websit] child 9297 exited on signal 7 (SIGBUS - core dumped) after xxx seconds

[root@blasty gs92437]# gdb /usr/sbin/php-fpm coredump-php-fpm.16339
GNU gdb (GDB) Red Hat Enterprise Linux 7.6.1-94.el7
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/sbin/php-fpm...Reading symbols from /usr/lib/debug/usr/sbin/php-fpm.debug...done.
done.
[New LWP 16339]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
Core was generated by `php-fpm: pool blasty           '.
Program terminated with signal 7, Bus error.
#0  lex_scan (zendlval=zendlval@entry=0x7ffdac3e3a48) at Zend/zend_language_scanner.c:1082
1082                    if (yych != '<') goto yy4;


Test script:
---------------
I uploaded core dump https://uploadfiles.io/41359

Bug is random and it`s end with 

WARNING: [pool websit] child 9297 exited on signal 7 (SIGBUS - core dumped) after xxx seconds

Please help to investigate that issue


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-12-23 11:08 UTC] nikic@php.net
-Status: Open +Status: Duplicate
 [2017-12-23 11:08 UTC] nikic@php.net
Very likely a duplicate of bug #52752.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Sun Oct 21 16:01:26 2018 UTC