php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #74333 Problem installing
Submitted: 2017-03-29 14:56 UTC Modified: 2017-04-11 14:19 UTC
From: php-dev79 at yopmail dot com Assigned: cmb (profile)
Status: Duplicate Package: stomp (PECL)
PHP Version: 7.1.3 OS: ubuntu trusty
Private report: No CVE-ID: None
 [2017-03-29 14:56 UTC] php-dev79 at yopmail dot com
Description:
------------
PHP Version 7.1.3-3+deb.sury.org~trusty+1

$ echo -ne 'no\n' | pear install /tmp/stomp-2.0.0.tgz

...
configure: creating ./config.status
config.status: creating config.h
config.status: executing libtool commands
running: make
/bin/bash /tmp/pear/temp/pear-build-root7ioOrI/stomp-2.0.0/libtool --mode=compile cc  -I. -I/tmp/pear/temp/stomp -DPHP_ATOM_INC -I/tmp/pear/temp/pear-build-root7ioOrI/stomp-2.0.0/include -I/tmp/pear/temp/pear-build-root7ioOrI/stomp-2.0.0/main -I/tmp/pear/temp/stomp -I/usr/include/php/20160303 -I/usr/include/php/20160303/main -I/usr/include/php/20160303/TSRM -I/usr/include/php/20160303/Zend -I/usr/include/php/20160303/ext -I/usr/include/php/20160303/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /tmp/pear/temp/stomp/stomp.c -o stomp.lo
libtool: compile:  cc -I. -I/tmp/pear/temp/stomp -DPHP_ATOM_INC -I/tmp/pear/temp/pear-build-root7ioOrI/stomp-2.0.0/include -I/tmp/pear/temp/pear-build-root7ioOrI/stomp-2.0.0/main -I/tmp/pear/temp/stomp -I/usr/include/php/20160303 -I/usr/include/php/20160303/main -I/usr/include/php/20160303/TSRM -I/usr/include/php/20160303/Zend -I/usr/include/php/20160303/ext -I/usr/include/php/20160303/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /tmp/pear/temp/stomp/stomp.c  -fPIC -DPIC -o .libs/stomp.o
/bin/bash /tmp/pear/temp/pear-build-root7ioOrI/stomp-2.0.0/libtool --mode=compile cc  -I. -I/tmp/pear/temp/stomp -DPHP_ATOM_INC -I/tmp/pear/temp/pear-build-root7ioOrI/stomp-2.0.0/include -I/tmp/pear/temp/pear-build-root7ioOrI/stomp-2.0.0/main -I/tmp/pear/temp/stomp -I/usr/include/php/20160303 -I/usr/include/php/20160303/main -I/usr/include/php/20160303/TSRM -I/usr/include/php/20160303/Zend -I/usr/include/php/20160303/ext -I/usr/include/php/20160303/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /tmp/pear/temp/stomp/php_stomp.c -o php_stomp.lo
libtool: compile:  cc -I. -I/tmp/pear/temp/stomp -DPHP_ATOM_INC -I/tmp/pear/temp/pear-build-root7ioOrI/stomp-2.0.0/include -I/tmp/pear/temp/pear-build-root7ioOrI/stomp-2.0.0/main -I/tmp/pear/temp/stomp -I/usr/include/php/20160303 -I/usr/include/php/20160303/main -I/usr/include/php/20160303/TSRM -I/usr/include/php/20160303/Zend -I/usr/include/php/20160303/ext -I/usr/include/php/20160303/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /tmp/pear/temp/stomp/php_stomp.c  -fPIC -DPIC -o .libs/php_stomp.o
/tmp/pear/temp/stomp/php_stomp.c: In function 'zif_stomp_read_frame':
/tmp/pear/temp/stomp/php_stomp.c:966:8: error: 'zend_fcall_info' has no member named 'function_table'
     fci.function_table = &ce->function_table;
        ^
/tmp/pear/temp/stomp/php_stomp.c:967:8: error: 'zend_fcall_info' has no member named 'symbol_table'
     fci.symbol_table = NULL;
        ^
In file included from /usr/include/php/20160303/Zend/zend_globals.h:28:0,
                 from /usr/include/php/20160303/Zend/zend_compile.h:688,
                 from /usr/include/php/20160303/Zend/zend_modules.h:26,
                 from /usr/include/php/20160303/Zend/zend_API.h:27,
                 from /usr/include/php/20160303/main/php.h:40,
                 from /tmp/pear/temp/stomp/php_stomp.c:25:
/usr/include/php/20160303/Zend/zend_globals_macros.h:46:33: error: 'zend_executor_globals' has no member named 'scope'
 # define EG(v) (executor_globals.v)
                                 ^
/tmp/pear/temp/stomp/php_stomp.c:983:25: note: in expansion of macro 'EG'
     fcc.calling_scope = EG(scope);
                         ^
make: *** [php_stomp.lo] Error 1
ERROR: `make' failed




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-04-11 14:19 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2017-04-11 14:19 UTC] cmb@php.net
Duplicate of bug #73748.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Aug 06 01:01:24 2020 UTC