php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #74316 i need a function __toInt
Submitted: 2017-03-27 04:46 UTC Modified: 2017-08-16 16:31 UTC
Votes:2
Avg. Score:3.0 ± 0.0
Reproduced:0 of 1 (0.0%)
From: xltxlm at qq dot com Assigned:
Status: Suspended Package: Scripting Engine problem
PHP Version: 7.1.3 OS: window 10
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2017-03-27 04:46 UTC] xltxlm at qq dot com
Description:
------------
sorry for my Poor English. i'am a chinese.


this is ok

https://gist.github.com/anonymous/2cd04f8d57866f4419abf821170ba370

this is not ok

https://gist.github.com/anonymous/a1d1b5d5fed9148ac17de9df5a5c6937




Expected result:
----------------
it can run normal 
https://gist.github.com/anonymous/a1d1b5d5fed9148ac17de9df5a5c6937



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-03-27 17:36 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Package: PHP Language Specification +Package: Scripting Engine problem -Assigned To: +Assigned To: cmb
 [2017-03-27 17:36 UTC] cmb@php.net
This appears to be a duplicate of bug #74289.
 [2017-03-27 17:57 UTC] cmb@php.net
-Status: Duplicate +Status: Suspended
 [2017-03-27 17:57 UTC] cmb@php.net
Oops, didn't really read the subject line! A magic ::__toInt()
method would require the RFC process, so feel free to start it[1]!

[1] <https://wiki.php.net/rfc/howto>
 [2017-08-16 16:31 UTC] cmb@php.net
-Assigned To: cmb +Assigned To:
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Nov 27 15:03:28 2021 UTC