php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #74243 Add milliseconds to DateTime values
Submitted: 2017-03-13 16:28 UTC Modified: 2017-10-31 21:58 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: bgarel at hotmail dot com Assigned: adambaratz (profile)
Status: Closed Package: PDO DBlib
PHP Version: Irrelevant OS: Linux
Private report: No CVE-ID: None
 [2017-03-13 16:28 UTC] bgarel at hotmail dot com
Description:
------------
Since the bugfix #54648, the pdo_dblib extension has forced the datetime format to YYYY-MM-DD HH:MM:SS.

Please add the milliseconds :
- with the returning format YYYY-MM-DD HH:MM:SS.F



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-03-13 16:31 UTC] adambaratz@php.net
-Status: Open +Status: Feedback
 [2017-03-13 16:31 UTC] adambaratz@php.net
There's another ticket open -- #72141 -- requesting that this format be customizable. Okay with you to merge the two?
 [2017-03-26 04:22 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 [2017-08-09 19:59 UTC] maxiwheat at gmail dot com
We are having the same issue on our side, would be great to have milliseconds back in our datetime resultsets, since we need them.
 [2017-10-13 11:38 UTC] bgarel at hotmail dot com
the absence of the milliseconds is a real regression.
I am not OK to merge with the issue 72141.

Is it possible to re open this issue ?
 [2017-10-31 21:54 UTC] adambaratz@php.net
Automatic comment on behalf of fandrieu@gmail.com
Revision: http://git.php.net/?p=php-src.git;a=commit;h=b72af30a534fb3ff2f899f1561fd021bdbc832e1
Log: Fix #74243: allow locales.conf to drive datetime format
 [2017-10-31 21:54 UTC] adambaratz@php.net
-Status: No Feedback +Status: Closed
 [2017-10-31 21:58 UTC] adambaratz@php.net
-Assigned To: +Assigned To: adambaratz
 [2017-10-31 21:58 UTC] adambaratz@php.net
Please see the conversation on the related pull request -- https://github.com/php/php-src/pull/2859. The suggestion is to set format via locales.conf or use the CAST function.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Thu Dec 13 22:01:26 2018 UTC