php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #74167 intval() considers string input as integer if string contains e(e notation)
Submitted: 2017-02-25 18:10 UTC Modified: 2017-02-25 19:06 UTC
From: stephin at stephin dot in Assigned:
Status: Not a bug Package: Strings related
PHP Version: 7.1.2 OS:
Private report: No CVE-ID: None
 [2017-02-25 18:10 UTC] stephin at stephin dot in
Description:
------------
php -r "echo intval('1e10');"

expected output: 1
actual output:  10000000000


i have tested this in some of other previous version series and found only php 7.1.x have this bug. 




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-02-25 18:22 UTC] spam2 at rhsoft dot net
this is for most cases a bugfix where before PHP7.1 when something returned scientific notation because of 0.0000000000001 you got weird results and lost data 

i have some workarounds in several scripts to prevent that which are ugly

if(strpos($out, 'E') || strpos($out, 'e'))
{
 $out = rtrim(number_format((float)$out, 20), '0');
}


http://php.net/manual/de/migration71.incompatible.php

Numerical string conversions now respect scientific notation
Integer operations and conversions on numerical strings now respect scientific notation. This also includes the (int) cast operation, and the following functions: intval() (where the base is 10), settype(), decbin(), decoct(), and dechex()
 [2017-02-25 18:30 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2017-02-25 18:30 UTC] requinix@php.net
As noted, this was a deliberate change, and it was part of an improvement to numeric strings as a whole.
https://wiki.php.net/rfc/invalid_strings_in_arithmetic
 [2017-02-25 18:41 UTC] stephin at stephin dot in
how can we call this string(354e3318D2174C4196I7371p2214T3183F6594X2108) as numerical string?
 [2017-02-25 18:54 UTC] stephin at stephin dot in
php 7.1.2

php -r "echo intval('354e3318D2174C4196I7371p2214T3183F6594X2108');"

output: 0

why should it be 0?  

other previous version series

php -r "echo intval('354e3318D2174C4196I7371p2214T3183F6594X2108');"

output: 354
 [2017-02-25 19:06 UTC] requinix@php.net
The numeric value extracted is 354e3318, which is float(INF). Converting that to int will give 0.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Dec 08 15:01:25 2019 UTC