php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #74086 A null byte character is added to the fetched data from mysql via pdo
Submitted: 2017-02-12 04:28 UTC Modified: 2017-02-12 11:55 UTC
From: omoon at lamolabo dot com Assigned:
Status: Duplicate Package: PDO MySQL
PHP Version: 7.0.15 OS: Linux / Mac
Private report: No CVE-ID: None
 [2017-02-12 04:28 UTC] omoon at lamolabo dot com
Description:
------------
When you fetch 16777212 byte data from MySQL database via pdo, a null byte character seems to be added to the end of the data.

Test script:
---------------
https://gist.github.com/omoon/69e5b39caf32e4a6aabd2410a0ef5851


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-02-12 11:11 UTC] adambaratz@php.net
-Package: PDO related +Package: PDO MySQL
 [2017-02-12 11:55 UTC] nikic@php.net
Duplicate of bug #74021.
 [2017-02-12 11:55 UTC] nikic@php.net
-Status: Open +Status: Duplicate
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC