php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #73979 imap_append return UID
Submitted: 2017-01-23 14:20 UTC Modified: 2020-10-16 15:45 UTC
From: clark at electrobeat dot dk Assigned: cmb (profile)
Status: Duplicate Package: IMAP related
PHP Version: 7.0.15 OS: Debian
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: clark at electrobeat dot dk
New email:
PHP Version: OS:

 

 [2017-01-23 14:20 UTC] clark at electrobeat dot dk
Description:
------------
---
From manual page: http://www.php.net/function.imap-append
---

When will imap funcitons support UIDPLUS so imap_append will return the UID?

Now its very complicated to get the new appended UID. After imap_append you have to reconnect to the IMAP server before you can see the new added message and in the meanwhile other messages could have been added.. So you need imap_search to filter out the new message appended..

This is not a very consistent way


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-10-08 14:40 UTC] cmb@php.net
-Type: Documentation Problem +Type: Feature/Change Request
 [2020-10-08 14:40 UTC] cmb@php.net
Well, not a doc bug, so reclassifying as feature request.
 [2020-10-16 15:45 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2020-10-16 15:45 UTC] cmb@php.net
Well, actually a duplicate of bug #65231.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Oct 27 04:01:24 2020 UTC