php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #73953 Bug in filter emails
Submitted: 2017-01-17 07:18 UTC Modified: 2017-01-17 07:30 UTC
From: alexv1rs at gmail dot com Assigned:
Status: Not a bug Package: Filter related
PHP Version: 5.6.29 OS:
Private report: No CVE-ID: None
 [2017-01-17 07:18 UTC] alexv1rs at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/filter.examples.validation
---
If we want to check email address like "11111/xxxx@yyyy.ru" - it's will be true. From 5.6 to 7.1

Test script:
---------------
if (filter_var('11111/xxxx@yyyy.zz', FILTER_VALIDATE_EMAIL)) {
    echo 'true';
}


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-01-17 07:30 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2017-01-17 07:30 UTC] requinix@php.net
Forward slashes are actually allowed in the username portion of an email address, as are other uncommonly used symbols like # ? { }.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Nov 30 07:05:54 2022 UTC