php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7390 readdir() still doesn't work under Solaris 2.4
Submitted: 2000-10-22 04:54 UTC Modified: 2000-11-28 04:14 UTC
From: muhlig at us dot edu dot pl Assigned: sniper (profile)
Status: Closed Package: Directory function related
PHP Version: 4.0.3pl1 OS: Solaris 2.4
Private report: No CVE-ID: None
 [2000-10-22 04:54 UTC] muhlig at us dot edu dot pl
The simple directory read script from PHP manual works now under Solaris 2.6. It, however, still doesnt work under Solaris 2.4. All the output is: Directory handle: Resource id #1 Files: 

SunOS helios 5.4 Generic_101945-60 sun4d sparc

'./configure' '--with-mysql=/usr/local' '--with-apache=../../apache/apache_1.3.12' '--with-zlib' '--enable-track-vars' '--enable-magic-quotes'

I have twin Solaris configurations: one with 2.4, one with 2.6, so I can compare the results between them.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-11-28 04:14 UTC] sniper@php.net
Fixed in CVS. 

--Jani
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Nov 29 02:01:23 2020 UTC