php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7383 configure script error - can't find pike modules directory
Submitted: 2000-10-21 17:48 UTC Modified: 2001-05-22 00:55 UTC
From: stevemc at real dot com Assigned:
Status: Closed Package: Other web server
PHP Version: 4.0.3pl1 OS: Linux 2.2.14/slackware 7.1
Private report: No CVE-ID: None
 [2000-10-21 17:48 UTC] stevemc at real dot com
With Roxen webserver version 2.1.143 / Pike v7.0 release 232 installed in /usr/local
** downloaded binary version, not source.

When running the following command line to configure prior to compiling:

./configure --with-roxen=/usr/local/roxen/server --with-roxen-zts

You will get an error as follows:

  checking for Roxen/Pike support... configure: error: Failed to figure out Pike module and include directories

I think the configure shell script can be changed to be more general.  In my case I was able to resolve by changing the following line in the configure script.

PIKE_MODULE_DIR="`$PIKE --show-paths 2>&1| grep lib/modules | sed -e 's/.*: //'`"

to 

PIKE_MODULE_DIR="`$PIKE --show-paths 2>&1| grep -e lib/modules -e lib/pike/modules | sed -e 's/.*: //'`"

i.e. add '-e lib/pike/modules' to patterns searched in grep since this seems to be how (some?) roxen pre-compiled binaries installs these.

I will be happy to help regression test this.

Thanks!
steve@real.com

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-04-29 05:32 UTC] sniper@php.net
Does this work with latest CVS snapshot from http://snaps.php.net/ ?

--Jani

 [2001-05-22 00:55 UTC] derick@php.net
Closing because of no feedback
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Aug 11 02:01:24 2020 UTC