php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #73818 Incorrect entries in get_html_translation_table
Submitted: 2016-12-26 22:04 UTC Modified: 2016-12-27 12:13 UTC
From: philip at van-diemen-de-jel dot nl Assigned: cmb (profile)
Status: Duplicate Package: Strings related
PHP Version: 5.6.29 OS: Linux
Private report: No CVE-ID: None
 [2016-12-26 22:04 UTC] philip at van-diemen-de-jel dot nl
Description:
------------
PHP-version: 5.6.29-0+deb8u1 (on Linux plesk4.duocast.net 3.16.0-4-amd64 #1 SMP Debian 3.16.36-1+deb8u2 (2016-10-19) x86_64)

Some entries obtained from get_html_translation_table have a missing closing semicolon.
E.g. [8402] => &nvlt  (should be <⃒)
[8421] => &bne
etc.

If you run the test script below (not the most sophisticated, but a quicky), the invalid entries will be in red.

Test script:
---------------
http://www.twentebestand.nl/pub/Test.php


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-12-27 12:13 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Package: unicodestring +Package: Strings related -Assigned To: +Assigned To: cmb
 [2016-12-27 12:13 UTC] cmb@php.net
Duplicate of bug #73817.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Dec 04 14:01:23 2020 UTC