php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #73791 0.14.0 does not build with php 5.3
Submitted: 2016-12-20 06:18 UTC Modified: 2018-07-08 13:57 UTC
From: php-bugs-2016 at ryandesign dot com Assigned: derick (profile)
Status: Assigned Package: vld (PECL)
PHP Version: Irrelevant OS: macOS Sierra 10.12.2
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2016-12-20 06:18 UTC] php-bugs-2016 at ryandesign dot com
Description:
------------
vld 0.14.0 builds fine with php 5.4 and later but not with php 5.3 (though it is advertised to be compatible with php 4 and later).


 ccache /usr/bin/clang -I. -I/opt/local/var/macports/build/_Users_rschmidt_macports_macports-ports_php_php-vld/php53-vld/work/vld-0.14.0 -DPHP_ATOM_INC -I/opt/local/var/macports/build/_Users_rschmidt_macports_macports-ports_php_php-vld/php53-vld/work/vld-0.14.0/include -I/opt/local/var/macports/build/_Users_rschmidt_macports_macports-ports_php_php-vld/php53-vld/work/vld-0.14.0/main -I/opt/local/var/macports/build/_Users_rschmidt_macports_macports-ports_php_php-vld/php53-vld/work/vld-0.14.0 -I/opt/local/include/php53/php -I/opt/local/include/php53/php/main -I/opt/local/include/php53/php/TSRM -I/opt/local/include/php53/php/Zend -I/opt/local/include/php53/php/ext -I/opt/local/include/php53/php/ext/date/lib -I/opt/local/include -I/opt/local/include -DHAVE_CONFIG_H -pipe -Os -arch x86_64 -c /opt/local/var/macports/build/_Users_rschmidt_macports_macports-ports_php_php-vld/php53-vld/work/vld-0.14.0/srm_oparray.c  -fno-common -DPIC -o .libs/srm_oparray.o
/opt/local/var/macports/build/_Users_rschmidt_macports_macports-ports_php_php-vld/php53-vld/work/vld-0.14.0/srm_oparray.c:636:20: error: no member named 'num' in 'struct _znode'
                        if (!op->result.num) {
                             ~~~~~~~~~~ ^
1 error generated.
make: *** [srm_oparray.lo] Error 1



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-07-08 13:57 UTC] cmb@php.net
-Assigned To: +Assigned To: derick
 [2018-07-08 13:57 UTC] cmb@php.net
> though it is advertised to be compatible with php 4 and later

That's apparently wrong.  Note that current 0.15.0-dev already
requires PHP 7.0.0 at least[1].

[1] <https://github.com/derickr/vld/commit/642b7e2171e1f8b6cbd65a4966c2eb7666aed657>
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Feb 17 01:01:25 2019 UTC