PHP :: Bug #73741 :: Won't compile against OpenSSL 1.1.0
php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #73741 Won't compile against OpenSSL 1.1.0
Submitted: 2016-12-14 19:57 UTC Modified: 2018-04-09 10:49 UTC
Votes:11
Avg. Score:4.3 ± 0.9
Reproduced:10 of 10 (100.0%)
Same Version:4 (40.0%)
Same OS:7 (70.0%)
From: ksb at inbox dot lv Assigned:
Status: Wont fix Package: Compile Failure
PHP Version: 5.6.29 OS: Linux 4.8 (Debian testing)
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2016-12-14 19:57 UTC] ksb at inbox dot lv
Description:
------------
PHP 5.6.29 ext/openssl (--with-openssl) won't compile against openssl 1.1.0, same as bug #72360 for php 7.0



Patches

php56-openssl11 (last revision 2017-04-28 21:31 UTC) by zsalab at zettasystem dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-03-07 19:53 UTC] moritz+php at mmnx dot de
Any update on this?
Not compiling for me on debian testing, php 5.6.30 and openssl 1.1.0e-1.
 [2017-03-07 19:57 UTC] spam2 at rhsoft dot net
which update do you expect besides PHP 5.x is EOL, PHP 7.0.x was GA for a year at 2016-12-14 and 7.1.x is GA too - if you need outdated PHP just use outdated openssl
 [2017-03-07 20:11 UTC] moritz+php at mmnx dot de
damn, you don't get the news when your employer uses old software.
thanks for the info!
 [2017-03-07 20:11 UTC] nikic@php.net
-Status: Open +Status: Wont fix
 [2017-03-07 20:11 UTC] nikic@php.net
PHP 5.6 will never compile against OpenSSL 1.1. Please use a newer version of PHP.
 [2018-04-09 10:28 UTC] hfisch at softfisch dot de
Actually PHP 5.6.31 does compile against OpenSSL 1.1.0. Later version PHP 5.6.35 does not again.

Using:

Debian 9.2
GCC version 6.3.0 20170516 (Debian 6.3.0-18)
PHP 5.6.31
OpenSSL 1.1.0f  25 May 2017

I'm getting some warnings during »make« but »make test« does not show anything suspicious when testing OpenSSL.

Comparison of the corresponding source code for the extension openssl shows compatability code for Openssl 1.1.0 which is left out in later version. Which means work has already been done to make it compatible and more work has been done to make it incompatible again.a
 [2018-04-09 10:49 UTC] nikic@php.net
Your PHP 5.6.31 is likely a distro-patched version with OpenSSL 1.1.0 support.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Tue Aug 21 00:01:27 2018 UTC