php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #73734 mcrypt is deprecated
Submitted: 2016-12-13 13:18 UTC Modified: 2017-01-07 15:29 UTC
From: your dot brother dot t at hotmail dot com Assigned: cmb (profile)
Status: Closed Package: mcrypt related
PHP Version: 7.1.0 OS:
Private report: No CVE-ID: None
 [2016-12-13 13:18 UTC] your dot brother dot t at hotmail dot com
Description:
------------
---
From manual page: http://www.php.net/function.mcrypt-get-iv-size
---

Though it is noted that the use of mcrypt_enc_get_iv_size function is preferred over mcrypt_get_iv_size, the documentation fails to address the fact that the latter is deprecated in PHP >= 7.1.0 and an E_DEPRECATED exception is raised.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-12-13 14:32 UTC] cmb@php.net
-Summary: mcrypt_get_iv_size is deprecated +Summary: mcrypt is deprecated -Status: Open +Status: Verified -Assigned To: +Assigned To: cmb
 [2016-12-13 14:32 UTC] cmb@php.net
Actually, the complete mcrypt extension is deprecated as of PHP 7.1 (and will be removed as of PHP 7.2), see <http://php.net/manual/en/migration71.deprecated.php#migration71.deprecated.ext-mcrypt>.
 [2016-12-14 10:57 UTC] cmb@php.net
Automatic comment from SVN on behalf of cmb
Revision: http://svn.php.net/viewvc/?view=revision&amp;revision=341386
Log: Fix #73734: mcrypt is deprecated

The patch has been provided by leigh.
 [2016-12-14 10:57 UTC] cmb@php.net
-Status: Verified +Status: Closed -Package: Documentation problem +Package: mcrypt related
 [2016-12-14 10:57 UTC] cmb@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.
 [2016-12-14 14:06 UTC] cmb@php.net
Automatic comment from SVN on behalf of cmb
Revision: http://svn.php.net/viewvc/?view=revision&amp;revision=341387
Log: Revert r341386 due to markup issues for now:

Fix #73734: mcrypt is deprecated

The patch has been provided by leigh.
........
 [2016-12-14 14:07 UTC] cmb@php.net
-Status: Closed +Status: Re-Opened
 [2016-12-14 23:55 UTC] leigh@php.net
@cmb what are the markup issues?

(I didn't commit the docs patch myself because I hate working with docs and I wanted some review :))

Let me know what I need to fix and I'll have another stab at it.
 [2016-12-15 01:33 UTC] cmb@php.net
The problem is that &warn.deprecated.function-7-1-0; already creates a <warning> element, but on several pages this entity is enclosed in an explicit <warning>. This results in duplicate warnings, see <http://i.imgur.com/AvExbPt.png>. Not sure how to solve this best.
 [2017-01-07 15:29 UTC] cmb@php.net
-Status: Re-Opened +Status: Closed
 [2017-01-07 15:29 UTC] cmb@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.

Fixed with <http://svn.php.net/viewvc?view=revision&revision=341620>.
 [2020-02-07 06:06 UTC] phpdocbot@php.net
Automatic comment on behalf of cmb
Revision: http://git.php.net/?p=doc/en.git;a=commit;h=e2e8e1359b3dcd03683e585e8f237aa03f4fefa4
Log: Fix #73734: mcrypt is deprecated
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Sep 19 18:03:37 2021 UTC