php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #73682 php-fpm "Reloading in progress" used 10 minitues
Submitted: 2016-12-08 03:37 UTC Modified: 2016-12-09 07:41 UTC
From: yywangzheng at 126 dot com Assigned:
Status: Closed Package: FPM related
PHP Version: 5.6.28 OS: centos 7.1
Private report: No CVE-ID: None
 [2016-12-08 03:37 UTC] yywangzheng at 126 dot com
Description:
------------
php-fpm log:

[07-Dec-2016 18:44:59] NOTICE: Reloading in progress ...
[07-Dec-2016 18:54:59] NOTICE: reloading: execvp("/usr/local/php/sbin/php-fpm", {"/usr/local/php/sbin/php-fpm", "--nodaemonize", "--fpm-config", "/usr/local/php/etc/php-fpm.conf"})
[07-Dec-2016 18:54:59] NOTICE: using inherited socket fd=7, "127.0.0.1:9000"
[07-Dec-2016 18:54:59] NOTICE: using inherited socket fd=7, "127.0.0.1:9000"
[07-Dec-2016 18:54:59] NOTICE: fpm is running, pid 1172
[07-Dec-2016 18:54:59] NOTICE: ready to handle connections

nginx log:
172.17.0.27 - - [07/Dec/2016:18:44:59 +0800] "POST /get HTTP/1.1" 200 787 "-" "-"
172.17.0.27 - - [07/Dec/2016:18:45:04 +0800] "POST /get HTTP/1.1" 499 0 "-" "-"
172.17.0.27 - - [07/Dec/2016:18:45:09 +0800] "POST /get HTTP/1.1" 499 0 "-" "-"
172.17.0.27 - - [07/Dec/2016:18:45:14 +0800] "POST /get HTTP/1.1" 499 0 "-" "-"
172.17.0.27 - - [07/Dec/2016:18:45:19 +0800] "POST /get HTTP/1.1" 499 0 "-" "-"

...

172.17.0.27 - - [07/Dec/2016:18:54:47 +0800] "POST /get HTTP/1.1" 499 0 "-" "-"
172.17.0.27 - - [07/Dec/2016:18:54:52 +0800] "POST /get HTTP/1.1" 499 0 "-" "-"
172.17.0.17 - - [07/Dec/2016:18:54:53 +0800] "POST /get HTTP/1.1" 502 0 "-" "-"
172.17.0.17 - - [07/Dec/2016:18:54:55 +0800] "POST /get HTTP/1.1" 502 0 "-" "-"
172.17.0.27 - - [07/Dec/2016:18:54:57 +0800] "POST /get HTTP/1.1" 499 0 "-" "-"
172.17.0.32 - - [07/Dec/2016:18:54:59 +0800] "GET /ping HTTP/1.1" 200 14 "-" "-"
172.17.0.32 - - [07/Dec/2016:18:54:59 +0800] "GET /ping HTTP/1.1" 200 14 "-" "-"
172.17.0.32 - - [07/Dec/2016:18:54:59 +0800] "GET /ping HTTP/1.1" 200 14 "-" "-"




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-12-08 03:45 UTC] yywangzheng at 126 dot com
php-fpm.conf:

process_control_timeout = 600
 [2016-12-09 07:41 UTC] yywangzheng at 126 dot com
-Status: Open +Status: Closed
 [2016-12-09 07:41 UTC] yywangzheng at 126 dot com
caused by php-fpm.conf:

process_control_timeout = 600
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Nov 27 05:05:53 2022 UTC